Last Comment Bug 716863 - blogspot.com pages are not properly framed after page is scrolled
: blogspot.com pages are not properly framed after page is scrolled
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 12 Branch
: ARM Android
: P1 normal (vote)
: Firefox 12
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
: 717138 719019 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 06:17 PST by Carla Nadastean
Modified: 2012-01-26 17:37 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
11+


Attachments
screenshot (58.57 KB, image/png)
2012-01-10 06:17 PST, Carla Nadastean
no flags Details
(1/2) Bounce back if overscrolled after flinging subdocument (2.27 KB, patch)
2012-01-20 09:09 PST, Kartikaya Gupta (email:kats@mozilla.com)
chrislord.net: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review
(2/2) Abort subdocument fling runnable when the subdoc stops scrolling (5.26 KB, patch)
2012-01-20 09:11 PST, Kartikaya Gupta (email:kats@mozilla.com)
chrislord.net: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Carla Nadastean 2012-01-10 06:17:25 PST
Created attachment 587284 [details]
screenshot

Build: 12.0a1 (2012-01-09) Device: HTC Desire Z (Android 2.3)

Steps to reproduce:
1. Go to http://android-developers.blogspot.com/2011/07/debugging-android-jni-with-checkjni.html
2. Try to scroll from the bottom of the page.

Expected Result:
Page content is scrolled successfully.

Actual Result:
Page content is scrolled but the page is no longer properly framed. (screenshot attached)
Comment 1 Carla Nadastean 2012-01-10 06:21:44 PST
Reproducible also on Aurora:
11.0a2 (2012-01-09) HTC Desire Z (Android 2.3)
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-12 10:11:28 PST
I looked at this a bit, and it seems to be happening because the subdocument scrolling code in browser.js takes over partway through the pan, so we get a little bit of panning (possibly into overscroll) in PZC, and then the iframe pans the rest of the touch movement. When the touch move stops, we don't bounce back because we're still sending the movement to the subdocument scroller.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-19 01:57:32 PST
*** Bug 719019 has been marked as a duplicate of this bug. ***
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-19 13:34:48 PST
*** Bug 717138 has been marked as a duplicate of this bug. ***
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-20 09:09:21 PST
Created attachment 590225 [details] [diff] [review]
(1/2) Bounce back if overscrolled after flinging subdocument

It only gets into this state if you touch down on a subdocument and pan/fling before the Gesture:ShowPress/Panning:Override event round-trip has time to complete.
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-20 09:11:33 PST
Created attachment 590227 [details] [diff] [review]
(2/2) Abort subdocument fling runnable when the subdoc stops scrolling

This is just so that the bounce-back happens faster if you happen to fling a subdoc very aggressively when you're already near the edge of the subdoc. Without this it could take a few seconds for the bounce-back to happen because it has to wait for the fling runnable to exhaust itself even though it's not visibly moving anything.
Comment 7 Chris Lord [:cwiiis] 2012-01-21 02:17:45 PST
Comment on attachment 590225 [details] [diff] [review]
(1/2) Bounce back if overscrolled after flinging subdocument

Review of attachment 590225 [details] [diff] [review]:
-----------------------------------------------------------------

Looks alright to me.
Comment 8 Chris Lord [:cwiiis] 2012-01-21 02:19:06 PST
Comment on attachment 590227 [details] [diff] [review]
(2/2) Abort subdocument fling runnable when the subdoc stops scrolling

Review of attachment 590227 [details] [diff] [review]:
-----------------------------------------------------------------

Also looks good.
Comment 11 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-23 10:34:02 PST
Comment on attachment 590225 [details] [diff] [review]
(1/2) Bounce back if overscrolled after flinging subdocument

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: It's possible to get stuck in overscroll after panning an iframe
Testing completed (on m-c, etc.): On m-c
Risk to taking this patch (and alternatives if risky): Potentially regression in fling behaviour
Comment 12 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-23 10:35:37 PST
Comment on attachment 590227 [details] [diff] [review]
(2/2) Abort subdocument fling runnable when the subdoc stops scrolling

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: If you fling a subdocument really hard and it hits the end and stops scrolling, the overall page may still remain in overscroll for a few more seconds rather than bouncing back immediately
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): potentially regressions in subdocument scrolling.
Comment 13 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-01-23 14:38:14 PST
Verified fixed in current Native trunk build on the LG Optimus Black, Android 2.2.2.
Comment 14 Alex Keybl [:akeybl] 2012-01-25 17:04:13 PST
Comment on attachment 590225 [details] [diff] [review]
(1/2) Bounce back if overscrolled after flinging subdocument

[Triage Comment]
Mobile only - approved for Aurora.
Comment 15 Matt Brubeck (:mbrubeck) 2012-01-26 17:36:56 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/b32116534dc2
Comment 16 Matt Brubeck (:mbrubeck) 2012-01-26 17:37:43 PST
(and the other patch landed on Aurora at the same time)
https://hg.mozilla.org/releases/mozilla-aurora/rev/bd5c7b73ce79

Note You need to log in before you can comment on or make changes to this bug.