Last Comment Bug 717174 - plugin is all black with wmode opaque on a xBGR display and no RENDER
: plugin is all black with wmode opaque on a xBGR display and no RENDER
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: unspecified
: x86 Solaris
: -- normal (vote)
: mozilla12
Assigned To: Ginn Chen
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-11 00:01 PST by Ginn Chen
Modified: 2012-01-16 19:32 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1004 bytes, patch)
2012-01-11 00:13 PST, Ginn Chen
karlt: review+
Details | Diff | Review

Description Ginn Chen 2012-01-11 00:01:05 PST
Open http://www.communitymx.com/content/source/E5141/wmodeopaque.htm
on a Sun Ray (xBGR display) and RENDER off.

Got a black rectangle.

The problem is gone if ipc is turned off.
Comment 1 Ginn Chen 2012-01-11 00:13:29 PST
Created attachment 587615 [details] [diff] [review]
patch

Does it look correct?

With xBGR display, FindVisual returns null for RGB24.
Then it will get to NS_ERROR("Need X falback surface, but visual failed");
Comment 2 Karl Tomlinson (ni?:karlt) 2012-01-11 01:26:27 PST
Comment on attachment 587615 [details] [diff] [review]
patch

Makes sense to me.
Comment 4 Justin Wood (:Callek) 2012-01-16 19:32:59 PST
https://hg.mozilla.org/mozilla-central/rev/720f1f3c2c0f

Note You need to log in before you can comment on or make changes to this bug.