Last Comment Bug 717190 - IndexedDB: follow-up of accessing IndexedDB API from chrome
: IndexedDB: follow-up of accessing IndexedDB API from chrome
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Gabor Krizsanits [:krizsa :gabor]
:
Mentors:
Depends on:
Blocks: 717504
  Show dependency treegraph
 
Reported: 2012-01-11 02:02 PST by Gabor Krizsanits [:krizsa :gabor]
Modified: 2012-03-22 11:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix for test_overlapping_transactions.js causing random failures (2.35 KB, patch)
2012-01-11 05:39 PST, Gabor Krizsanits [:krizsa :gabor]
jonas: review+
Details | Diff | Review

Description Gabor Krizsanits [:krizsa :gabor] 2012-01-11 02:02:17 PST
Not all the mochi tests were converted to xpcshell test hence I created this bug to convert the rest of the tests as well and add other small fixtures to the new existing xpcshell tests as well if needed. This is a followup of bug 587797.
Comment 1 Gabor Krizsanits [:krizsa :gabor] 2012-01-11 05:39:41 PST
Created attachment 587668 [details] [diff] [review]
fix for test_overlapping_transactions.js causing random failures

Since this test become an xpcshell test it can cause some issues when finishes too early some times (hits and assertion that results in a crash). Sicking: do you think the test stays valid after my fix?
Comment 2 Gabor Krizsanits [:krizsa :gabor] 2012-02-06 05:51:16 PST
https://tbpl.mozilla.org/?tree=Try&rev=3dbef98b8cb0
Comment 4 Ed Morley [:emorley] 2012-02-07 12:15:16 PST
https://hg.mozilla.org/mozilla-central/rev/9d9ae33d442c

Note You need to log in before you can comment on or make changes to this bug.