Closed Bug 717218 Opened 8 years ago Closed 8 years ago

Paste from Excel generates an image instead of an HTML table

Categories

(Core :: DOM: Editor, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 714115

People

(Reporter: mdalco, Assigned: bbondy)

References

()

Details

(Keywords: regression, Whiteboard: [GS])

If I try to paste a simple Excel table to a wysiwyg Html editor in Firefox I obtain an image pasted instead of an html styled table.
This behaviour changed from Firefox 9 in Windows, since in previous versions it worked fine.
This brokes Gmail usage, since is no more possible to paste from Excel: the Gmail editor doesn't manage pasted images and remove them when you send the message, losing the pasted information.

Steps to reproduce this bug in Windows:
1. Create a table of values in Microsoft Excel (my version is 2007)
2. Copy the table
3. Open http://ckeditor.com/demo with updated Firefox (my version is 9.0.1). Alternatively create a new message in Gmail with html editor enabled.
4. Paste the table in the html editor.

You'll see a pasted image, url encoded, instead of an html table as previous versions of Firefox.
This bug also affect Thunderbird (since version 9), as reported on this GetSatisfaction thread: http://getsatisfaction.com/mozilla_messaging/topics/cannot_paste_spreadsheet_when_compose_message
Corresponding MozillaZine thread, note that not all TB/Excel configurations seem to show this issue - http://forums.mozillazine.org/viewtopic.php?f=39&t=2399777
Possibly related, bug 714115 reporting HTML-pasting issues from MS Word, pasting plain text as fallback. This was identified as a regression from bug 598289, thus it might be worth to test that regression window if it matches for the issue seen here as well.
Keywords: regression
Brian, could you please take a look?
Assignee: nobody → netzen
Unfortunately I couldn't reproduce this with Excel 2010. I haven't tried 2007 specifically yet but I suspect it'll be the same.  I did try Word 2003 and it worked fine too but in bug 714115 it was reported that Word 2003 should have the problem.
I'll try with Windows XP a bit later, I suspect maybe it's the OS.
Maybe the difference is locale version of OS or FF.
I have this problem with FF and TB and with tables from Openoffice.org, Excel 2007, Excel 2010 and also LibreOffice. I tried it on Windows XP and Windows 7 with the same result: image instead of table.
I use Czech-Locale.
What lokale are using the others with or without this error?
Could you follow the instructions in bug 714115 comment 17. I think whatever that bug's issue is, is the same as this one.

I'm using the US English build but I don't think it would be related to that.
Now that you mention it I think you are exactly right. It is probably because we try to read in the CF_HTML version.  And if you use a comma separator that will probably fail with fscanf %f format specifier.
Do you have a comma instead of a period for decimal place numbers?
If that's the problem the spec is wrong as it says the version should always be "0.9".  But we should handle the case with a ,.
I can reproduce this now and can confirm it's the same as bug 714115.  Please follow that bug for more info on the fix.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 714115
You need to log in before you can comment on or make changes to this bug.