Last Comment Bug 717252 - JS Test Failure on js/src/tests/e4x/Regress/regress-323338-2.js
: JS Test Failure on js/src/tests/e4x/Regress/regress-323338-2.js
Status: RESOLVED FIXED
js-triage-needed
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- critical (vote)
: mozilla12
Assigned To: Brian Hackett (:bhackett)
:
Mentors:
: 717716 (view as bug list)
Depends on:
Blocks: langfuzz 717716
  Show dependency treegraph
 
Reported: 2012-01-11 08:37 PST by Christian Holler (:decoder)
Modified: 2012-03-01 13:50 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (718 bytes, patch)
2012-01-12 15:48 PST, Brian Hackett (:bhackett)
dvander: review+
Details | Diff | Splinter Review

Description Christian Holler (:decoder) 2012-01-11 08:37:49 PST
The mentioned test asserts on mozilla-central revision 4de07a341aab (options -m -n -a) with:

Assertion failure: [infer failure] Missing type pushed 1: [0x7f9f54b006d0], at js/src/jsinfer.cpp:349
Comment 1 Brian Hackett (:bhackett) 2012-01-12 15:47:19 PST
*** Bug 717716 has been marked as a duplicate of this bug. ***
Comment 2 Brian Hackett (:bhackett) 2012-01-12 15:48:24 PST
Created attachment 588217 [details] [diff] [review]
patch

Bug 712714 erroneously removed inference type propagation for the second value pushed by JSOP_CALLXMLNAME, though this op still pushes two values.
Comment 3 Brian Hackett (:bhackett) 2012-01-13 17:45:50 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/7ea17887bc78
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-01-14 01:50:38 PST
https://hg.mozilla.org/mozilla-central/rev/7ea17887bc78

Note You need to log in before you can comment on or make changes to this bug.