Create nsIWebBrowserAccessible interface

VERIFIED DUPLICATE of bug 70219

Status

()

Core
Embedding: APIs
P1
normal
VERIFIED DUPLICATE of bug 70219
17 years ago
16 years ago

People

(Reporter: Aaron Leventhal, Assigned: Aaron Leventhal)

Tracking

Trunk
mozilla1.1alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
We need to expose the DocShell's GetZoom and SetZoom in the embedding API.

This should be done through a new interface, nsIWebBrowserAccessible, which you
can get to by QI from nsIWebBrowser.

nsCOMPtr webBrowserAccessible(do_QueryInterface(webBrowser));
if (webBrowserAccessible) {
   float oldZoom, newZoom; /* Zoom value of 1.0 = normal (100%) size */
   webBrowserAccessible->GetZoom(&oldZoom);
   newZoom = oldZoom + 0.5; /* increase by another 50% */
   webBrowserAccessible->SetZoom(newZoom); /* takes float */
}

This is not a blocker for embedding 1.0.

Updated

17 years ago
OS: Linux → All
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.1

Comment 1

17 years ago
duping.

*** This bug has been marked as a duplicate of 70219 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Moving API bug ownership to David Epstein.
QA Contact: mdunn → depstein

Comment 3

17 years ago
Correction: Changing QA contact for the Embed API bugs to David Epstein.

Comment 4

17 years ago
reassigning QA contact to Dharma. He's working on accessibility.
QA Contact: depstein → dsirnapalli

Comment 5

17 years ago
This bug is duplicate of 70219. changing to verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.