Last Comment Bug 717373 - Remove the textarea fallback from the Source Editor
: Remove the textarea fallback from the Source Editor
Status: RESOLVED FIXED
[sourceeditor][killthem]
: dev-doc-complete
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: Firefox 13
Assigned To: Rob Campbell [:rc] (:robcee)
:
Mentors:
Depends on:
Blocks: 717384
  Show dependency treegraph
 
Reported: 2012-01-11 13:07 PST by Mihai Sucan [:msucan]
Modified: 2012-04-28 12:02 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove text area (26.77 KB, patch)
2012-02-03 09:57 PST, Rob Campbell [:rc] (:robcee)
no flags Details | Diff | Review
remove text area (26.67 KB, patch)
2012-02-03 10:22 PST, Rob Campbell [:rc] (:robcee)
mihai.sucan: review+
Details | Diff | Review

Description Mihai Sucan [:msucan] 2012-01-11 13:07:01 PST
The current textarea fallback cannot keep up with the changes planned ahead for the Source Editor (things like autocomplete, debugger ruler, and so on).

We should remove the textarea fallback code, since we won't be able to maintain it and our developer tools cannot use it (for example the debugger and the style editor).

Ehsan: can you please point us to specific requirements (if any) we should meet before we remove the textarea fallback? Is the polish we did in the past sufficient to allow us to do that? (now that Orion is enabled by default)

Thank you very much!
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2012-01-11 13:33:00 PST
If the devtools team is satisfied with the current quality of the Orion service, I'm fine with it!  :-)
Comment 2 Rob Campbell [:rc] (:robcee) 2012-01-12 08:49:16 PST
it's painful maintaining the two. We should do this, but I would like some feedback from David Bolter and the a11y group before final decision. CCing...
Comment 3 alexander :surkov 2012-01-19 04:32:53 PST
(In reply to Rob Campbell [:rc] (robcee) from comment #2)
> it's painful maintaining the two. We should do this, but I would like some
> feedback from David Bolter and the a11y group before final decision. CCing...

Marco, ping?
Comment 4 Marco Zehe (:MarcoZ) 2012-01-19 07:11:24 PST
The current style editor is not at all useable for someone using a screen reader. The cursor appears to be stuck on two 0x00fc characters, the style information is a big chunk of spans or so underneath a div inside the accessible tree, no line numbers and no way to discern which belongs to what.
Comment 5 David Bolter [:davidb] 2012-01-19 07:16:11 PST
Marco, sorry I led you astray. A better way to test Orion is: tools, web developer, scratchpad.

Where is the pref to set it to use the fallback editor?
Comment 6 Cedric Vivier [:cedricv] 2012-01-19 07:18:52 PST
(In reply to David Bolter [:davidb] from comment #5)
> Where is the pref to set it to use the fallback editor?

devtools.editor.component => textarea
Comment 7 Mihai Sucan [:msucan] 2012-01-19 07:22:22 PST
(In reply to David Bolter [:davidb] from comment #5)
> Marco, sorry I led you astray. A better way to test Orion is: tools, web
> developer, scratchpad.
> 
> Where is the pref to set it to use the fallback editor?

In about:config, the devtools.editor.component pref. One can change it to "orion" or to "textarea", depending on what one intends to use.

Thank you Marco and David for looking into it! Please let us know the results of your testing and any recommendations you have.
Comment 8 David Bolter [:davidb] 2012-01-19 07:25:47 PST
Thanks Cedric.

Mihai, I understand well the pain of multiple code paths.

I want to better understand the maintenance/upkeep pain details in this case, because not being able to use the developer tools is also pain. I might be able to find a resource if necessary.

In the meantime I'm waiting on my IBM contact for Orion a11y roadmap info.
Comment 9 Mihai Sucan [:msucan] 2012-01-19 07:37:02 PST
(In reply to David Bolter [:davidb] from comment #8)
> Thanks Cedric.
> 
> Mihai, I understand well the pain of multiple code paths.
> 
> I want to better understand the maintenance/upkeep pain details in this
> case, because not being able to use the developer tools is also pain. I
> might be able to find a resource if necessary.
> 
> In the meantime I'm waiting on my IBM contact for Orion a11y roadmap info.

That's much appreciated! I would very much like Orion to become more accessible.

The divs and the spans are there, as Marco points out. I assume that with some aria attributes and other accessibility-related improvements Orion can be much more usable. Until then, I agree, it's not as easy to use Orion as it is the textarea fallback.

Maintenance is a problem indeed. However we are gradually working on adding source code editor-specific features. For example now I am working on the debugger gutter (bug 707987). This leaves us in a state where we can no longer use the textarea fallback, unless we go ahead and re-implement parts of Orion, even Orion itself. That is what we want to avoid in the first place by using Orion and by not forking the project (we make upstream contributions to make sure the Orion code runs as good as possible within the Firefox environment).

Similar to the case of the JS Debugger we have the Style Editor which currently fails to work with the textarea fallback.

We can't easily keep the textarea fallback usable while going forward with features we need built into the developer tools.

Please let me know if you need further details or if you have any other questions. Thank you!
Comment 10 Rob Campbell [:rc] (:robcee) 2012-02-03 09:57:30 PST
Created attachment 594224 [details] [diff] [review]
remove text area

did I miss anything?
Comment 11 Rob Campbell [:rc] (:robcee) 2012-02-03 10:22:24 PST
Created attachment 594235 [details] [diff] [review]
remove text area

restored ui check
Comment 12 Mihai Sucan [:msucan] 2012-02-06 12:02:05 PST
Comment on attachment 594235 [details] [diff] [review]
remove text area

Review of attachment 594235 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thank you!

::: browser/app/profile/firefox.js
@@ +1097,3 @@
>  //   "orion" - this is the Orion source code editor from the Eclipse project. It
>  //   provides programmer-specific editor features such as syntax highlighting,
>  //   indenting and bracket recognition. It may not be appropriate for all

Probably we want to update the orion component description, since the a11y notes are no longer relevant because we remove the textarea fallback. Thoughts?
Comment 13 Rob Campbell [:rc] (:robcee) 2012-02-07 13:54:41 PST
(In reply to Mihai Sucan [:msucan] from comment #12)
> Comment on attachment 594235 [details] [diff] [review]
> remove text area
> 
> Review of attachment 594235 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good. Thank you!
> 
> ::: browser/app/profile/firefox.js
> @@ +1097,3 @@
> >  //   "orion" - this is the Orion source code editor from the Eclipse project. It
> >  //   provides programmer-specific editor features such as syntax highlighting,
> >  //   indenting and bracket recognition. It may not be appropriate for all
> 
> Probably we want to update the orion component description, since the a11y
> notes are no longer relevant because we remove the textarea fallback.
> Thoughts?

yeah, good call, I'll fix, update the patch and land it.

thanks!
Comment 14 Rob Campbell [:rc] (:robcee) 2012-02-08 06:49:45 PST
https://hg.mozilla.org/integration/fx-team/rev/250f556a5d49
Comment 15 Tim Taubert [:ttaubert] 2012-02-09 00:32:57 PST
https://hg.mozilla.org/mozilla-central/rev/250f556a5d49
Comment 16 Mihai Sucan [:msucan] 2012-02-09 12:42:08 PST
Please document the removal of the textarea fallback component from the Source Editor in Firefox 13. Thank you!
Comment 17 Eric Shepherd [:sheppy] 2012-04-28 12:02:11 PDT
This is now mentioned on Firefox 13 for developers; there is no other relevant place to mention it.

Note You need to log in before you can comment on or make changes to this bug.