Closed Bug 717458 Opened 11 years ago Closed 8 years ago

Comcast/Xfinity inserts bookmarks into places.sqlite with missing required values ("Found a page without a GUID!")

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: MattN, Unassigned)

Details

Attachments

(1 file)

Assertion failure: !haveNullGuids && "Found a page without a GUID!", at /mozilla-central/toolkit/components/places/Database.cpp:1719
encountered on shutdown which leads to "Segmentation fault: 11".

I was required to install some Comcast software (ComcastDesktopInstaller_FarmC_1108.pkg) in order to activate my internet service in November and it installed 8 bookmarks in Firefox.  I deleted them from the bookmark UI but entries remained in moz_places.  I'm not sure what the database other database entries looked like before I deleted them. Some of the required columns are missing data such as `rev_host` and `guid`.  The lack of a guid leads to this assertion failure in debug builds.

Deleting the moz_places entries shown in the screenshot gets rid of the assertion failure.

I can provide a link to a download of the software for Mac if desired but I'm not sure if I should provide it publicly.
Is the goal to get them to do it properly, or not to do it at all? I'd personally prefer other applications don't mess with my bookmarks, ever, without my explicit permission, and I'm gonna take a wild guess Comcast didn't ask you to do that.
(In reply to Chris Lawson from comment #1)
> Is the goal to get them to do it properly, or not to do it at all?

Not to do it at all.
Nobody contacted anyone. 
We never had duplicate on this it seems. 
I doubt the issue is still valid.

I will close as INVALID. but if you still have the issue, please REOPEN.

That said, there is a more general issue about allowing bookmarks that would be invalid or create issues in the browser.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 8 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.