Magnifying glass function to display pictures in center of tab is broken in Firefox 9+ (lucien-segura.fr)

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: epinal99-bugzilla2, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

9 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

1) Open http://www.lucien-segura.fr/contents/fr/d5.html (painter's website)
2) Click on the 1st picture thumbnail (with magnifying glass) in the 1st line and observe
3) Scroll down the webpage completely
4) Click on the 1st picture thumbnail (with magnifying glass) in the 4th line and observe



Actual results:

* 1st picture in the 1st line: a large picture is displayed on a black overlay in the tab window (almost centered)
* 1st picture in the 4th line: only the black overlay is visible

It's broken in FF9+ (FF12 too) but not in FF8.0.1.

In FF9+, the display of the large picture depends on the position of the vertical scrollbar that's why the picture display is not centered in the tab window and can be not visible.
(Reporter)

Updated

7 years ago
Keywords: regression
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Comment 1

7 years ago
Created attachment 588001 [details]
www.lucien-segura.fr-contents-fr-d5.html_FF9.0.1_scrollbar.on.top
(Reporter)

Comment 2

7 years ago
Created attachment 588002 [details]
www.lucien-segura.fr-contents-fr-d5.html_FF9.0.1_scrollbar.in.middle

Updated

7 years ago
Blocks: 679971
(Reporter)

Comment 3

7 years ago
Correction: I tested with Aurora (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a2) Gecko/20120112 Firefox/11.0a2) and it works, large pictures are displayed in the center of the tab window, whatever the position of the scrollbar.

So behaviour broken in FF9 and FF12, working in FF10.
(Reporter)

Comment 4

7 years ago
I'm not able to reproduce this bug with FF12+ so I close it as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.