Background flickering while an image is loading

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: jerome.vouillon, Assigned: mattwoodrow)

Tracking

({regression})

9 Branch
x86_64
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I have a Web page where an image element is superposed over a canvas
element.  The idea is that the canvas element provides a low quality
version of an image which is eventually replaced by a final higher
quality image.

Previously, the image contents was loaded progressively over the canvas,
in a smooth way (the part not yet loaded was transparent). Now, I get
a dark background (instead of the canvas) for a short time when the
image starts loading. Then, the canvas becomes visible again, while
being progressively replaced by the image. The bug is especially
visible over a slow network.


To see this, go to the following page:

   http://www.pps.jussieu.fr/~vouillon/bug2/

Then, when you click on one of the small images on the page, a
larger version of the image is displayed as described above.
Some images are small and loaded quickly, so you may have to click
on several images before seeing the flickering.


Using mozregression, it seems the regression was introduced by
the following changeset:

    changeset:   79230:8b89d7037306
    user:        Matt Woodrow <mwoodrow@mozilla.com>
    date:        Wed Oct 26 16:24:58 2011 +1300
    summary:     Bug 695275 - Fix conversion of ThebesLayers to ImageLayers. r=roc


The bug still occurs in Firefox Nightly.
(Reporter)

Updated

7 years ago
Keywords: regression
Duplicate of this bug: 717323
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Yeah, this looks wrong.  Over here (on Mac) I never even see the canvas previews, just the black, with a nightly.

Matt, can you take a look please?
Assignee: nobody → matt.woodrow
Blocks: 695275
Is this still happening?

Comment 4

5 years ago
Jérôme, is it still an issue on your side with FF32?
Flags: needinfo?(jerome.vouillon)
(Reporter)

Comment 5

5 years ago
No, this is fixed now. Thanks!
Flags: needinfo?(jerome.vouillon)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.