Closed Bug 717611 Opened 8 years ago Closed 6 months ago

Web Console clear button does not clear cached errors

Categories

(DevTools :: Console, defect, P2)

defect

Tracking

(firefox67 fixed)

RESOLVED FIXED
Firefox 67
Tracking Status
firefox67 --- fixed

People

(Reporter: msucan, Assigned: nchevobbe)

References

Details

Attachments

(2 files)

Follow up from bug 611032 comment 61:

"- nsIConsoleService does not have a way to remove individual messages, or to clear all messages associated to a specific inner window ID. This means that the Web Console clear button only temporarily clears nsIScriptErrors. They show again after reopen.

This should be fixed inside the nsIConsoleService. The 250 messages limit is also hard coded..."

An alternate "solution" is to allow the Clear button to clear all of the messages, at once, from the nsIConsoleService. Meaning that any cached errors in the other tabs are lost. This is only a workaround - what we really need is a way to remove messages associated to the inner window ID we want.

We might want to base this bug fix on top of bug 692824.
Priority: -- → P2
Not touches in the past 6 years. No user complaints. Closing.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Product: Firefox → DevTools

(it's fixed BTW)
it's not, I might investigate a bit

Resolution: WONTFIX → FIXED
Assignee: nobody → nchevobbe
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1530695

This will allow devtools to clear cached error messages, like
we already can with ConsoleAPI messages.

We were clearing the ConsoleAPI messages, but not the one
issued by the ConsoleService. A previous patch added
Services.console.resetWindow, so we can use it in clearMessagesCache.

Depends on D21693

TRY push

I'm really not confident of my C++ skills, but it fixes the console issue.

Status: REOPENED → ASSIGNED
Attachment #9047698 - Attachment description: Bug 717611 - Clear ConsoleService cached messages in webconsole actor's clearMessagesCache; r=bgrins. → Bug 717611 - Clear ConsoleService cached messages in webconsole actor's clearMessagesCache; r=Honza.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6da9d84ec243
Add nsConsoleService::ResetWindow to clear messages for a given window id; r=baku.
https://hg.mozilla.org/integration/autoland/rev/60f067345542
Clear ConsoleService cached messages in webconsole actor's clearMessagesCache; r=Honza.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
You need to log in before you can comment on or make changes to this bug.