Last Comment Bug 717863 - default pagesize is 8192 on Solaris/SPARC
: default pagesize is 8192 on Solaris/SPARC
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: Sun Solaris
: -- normal (vote)
: mozilla12
Assigned To: Ginn Chen
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-12 22:52 PST by Ginn Chen
Modified: 2012-01-16 19:33 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (950 bytes, patch)
2012-01-12 23:00 PST, Ginn Chen
igor: review+
Details | Diff | Review

Description Ginn Chen 2012-01-12 22:52:39 PST
With Firefox 10/Solaris SPARC, Firefox hangs with infinite calls to memcntl(0xEB4FB000, 4096, MC_ADVISE, MADV_DONTNEED, 0, 0), it returns EINVAL because the addr is not multiple of pagesize.
Comment 1 Ginn Chen 2012-01-12 23:00:13 PST
Created attachment 588326 [details] [diff] [review]
patch
Comment 3 Justin Wood (:Callek) 2012-01-16 19:33:35 PST
https://hg.mozilla.org/mozilla-central/rev/a3bdb21f350c

Note You need to log in before you can comment on or make changes to this bug.