Last Comment Bug 718072 - WeakMaps constructor doesn't always get initialized on the global object
: WeakMaps constructor doesn't always get initialized on the global object
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Bobby Holley (:bholley) (busy with Stylo)
:
:
Mentors:
: 697928 (view as bug list)
Depends on:
Blocks: 702353
  Show dependency treegraph
 
Reported: 2012-01-13 14:28 PST by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2012-11-28 08:06 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (2.41 KB, patch)
2012-01-13 14:30 PST, Bobby Holley (:bholley) (busy with Stylo)
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Bobby Holley (:bholley) (busy with Stylo) 2012-01-13 14:28:42 PST
My spidey senses tell me that we could use some consolidation here. But in the mean time, here's the patch.
Comment 1 Bobby Holley (:bholley) (busy with Stylo) 2012-01-13 14:30:45 PST
Created attachment 588528 [details] [diff] [review]
patch v1
Comment 2 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-17 02:12:33 PST
Comment on attachment 588528 [details] [diff] [review]
patch v1

Review of attachment 588528 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/vm/GlobalObject.cpp
@@ +49,5 @@
>  #include "frontend/BytecodeEmitter.h"
>  #include "vm/GlobalObject-inl.h"
>  
>  #include "jsobjinlines.h"
> +#include "jsweakmap.h"

Could you insert this in the js* non-inlines list above?  The current inclusions look a disordered mess, but that's no reason to compound the problem.
Comment 3 Bobby Holley (:bholley) (busy with Stylo) 2012-01-18 19:12:36 PST
Pushed to inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/5bc8dcf80474
Comment 4 Matt Brubeck (:mbrubeck) 2012-01-19 10:47:42 PST
https://hg.mozilla.org/mozilla-central/rev/5bc8dcf80474
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2012-11-28 08:06:55 PST
*** Bug 697928 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.