Last Comment Bug 718133 - Remove keyboard shortcuts for zooming to 1:1 scale when viewing standalone images
: Remove keyboard shortcuts for zooming to 1:1 scale when viewing standalone im...
Status: RESOLVED FIXED
[mentor=jwein][lang=c++]
:
Product: Core
Classification: Components
Component: Layout: Images (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Diogo Golovanevsky Monteiro [:diogogmt]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-13 18:22 PST by Jared Wein [:jaws] (please needinfo? me)
Modified: 2012-01-16 03:30 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Removed shortchut Shift+plus/minus for zooming image to 1:1 scale (1.44 KB, patch)
2012-01-13 19:06 PST, Diogo Golovanevsky Monteiro [:diogogmt]
jaws: feedback+
Details | Diff | Splinter Review
Patch v2 (1.46 KB, patch)
2012-01-13 21:19 PST, Diogo Golovanevsky Monteiro [:diogogmt]
roc: review+
Details | Diff | Splinter Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-01-13 18:22:32 PST
There exists two keyboard shortcuts, shift+plus and minus, to scale a shrink-to-fit image to 1:1 scale and back. These shortcuts are extremely hidden and exist at a cost of maintainability to ImageDocument.

We should just remove these shortcuts, since users can already do ctrl+plus and ctrl+minus to zoom in and out of the image.
Comment 1 Diogo Golovanevsky Monteiro [:diogogmt] 2012-01-13 19:06:34 PST
Created attachment 588586 [details] [diff] [review]
Removed shortchut Shift+plus/minus for zooming image to 1:1 scale
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-01-13 20:09:00 PST
Comment on attachment 588586 [details] [diff] [review]
Removed shortchut Shift+plus/minus for zooming image to 1:1 scale

Review of attachment 588586 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Diogo! I've passed the patch on to review from Robert O'Callahan. Can you also follow the steps in Marco's blog post and update your patch to have a user line as well as a summary?
Comment 3 Diogo Golovanevsky Monteiro [:diogogmt] 2012-01-13 21:19:59 PST
Created attachment 588597 [details] [diff] [review]
Patch v2
Comment 4 Jared Wein [:jaws] (please needinfo? me) 2012-01-14 22:33:43 PST
https://hg.mozilla.org/integration/fx-team/rev/2cba23414a5c

Congratulations on your first patch Diogo!
Comment 5 Tim Taubert [:ttaubert] 2012-01-16 02:33:48 PST
https://hg.mozilla.org/mozilla-central/rev/2cba23414a5c
Comment 6 Diogo Golovanevsky Monteiro [:diogogmt] 2012-01-16 03:30:22 PST
(In reply to Jared Wein [:jwein and :jaws] from comment #4)
> https://hg.mozilla.org/integration/fx-team/rev/2cba23414a5c
> 
> Congratulations on your first patch Diogo!

Thanks a lot for the help Jared :)

Note You need to log in before you can comment on or make changes to this bug.