Closed Bug 718186 Opened 8 years ago Closed 8 years ago

mulitple reports of 'abort: 00changelog.i@c27a041a2ce4: unknown parent!' after hg update

Categories

(mozilla.org Graveyard :: Server Operations, task, major)

x86
macOS
task
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Pike, Assigned: cshields)

References

Details

There are multiple people that report problems with pulling and cloning, with error messages like

$ hg pull
pulling from http://hg.mozilla.org/releases/comm-aurora
searching for changes
all local heads known remotely
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@c27a041a2ce4: unknown parent! 

http://groups.google.com/group/mozilla.dev.l10n/browse_frm/thread/ac27af4aa35d32d5# has more.

I've run into this once, but couldn't reliably reproduce it.

Filing to track this.

Rimas, Sander, could you paste the output of 

hg pull -v

to get additional data?
-v didn't add anything more, --debug is a bit more verbose, but still not much info. At least not for me..

$ hg pull --debug
using http://hg.mozilla.org/releases/comm-aurora
sending capabilities command
pulling from http://hg.mozilla.org/releases/comm-aurora
query 1; heads
sending batch command
searching for changes
all local heads known remotely
sending getbundle command
adding changesets
changesets: 1 chunks
add changeset d9df36db99a3
transaction abort!
rollback completed
abort: 00changelog.i@c27a041a2ce4: unknown parent!
$ hg pull --debug
using http://hg.mozilla.org/mozilla-central/
sending capabilities command
pulling from http://hg.mozilla.org/mozilla-central/
query 1; heads
sending batch command
searching for changes
taking initial sample
searching: 2 queries
query 2; still undecided: 11035, sample size is: 200
sending known command
2 total queries
sending getbundle command
adding changesets
changesets: 1 chunks
add changeset cf15bf30ba2c
transaction abort!
rollback completed
abort: 00changelog.i@c713003d3226: unknown parent!
those of you who are having this problem, can you please pass along your hg client version?  thanks
$ hg --version
Mercurial Distributed SCM (version 2.0.2)

installed with easy_install -U mercurial (Debian Squeeze)
It has started working for all repositories but releases/comm-aurora

add changeset 0a227516d030
transaction abort!
rollback completed
abort: 00changelog.i@44a93d2f172d: unknown parent!

The Hg client is 64bit version 2.0.2 running on Win7
> hg clone http://hg.mozilla.org/mozilla-central/ 
destination directory: mozilla-central
requesting all changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@27a7f197c6fc: unknown parent!
hg clone https://hg.mozilla.org/comm-central/
requesting all changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@3b30e81cd037: unknown parent!

This is with hg version 2.0.1+20111201
(In reply to Stefan [:stefanh] from comment #7)
> hg clone https://hg.mozilla.org/comm-central/
> requesting all changes
> adding changesets
> transaction abort!
> rollback completed
> abort: 00changelog.i@3b30e81cd037: unknown parent!
> 
> This is with hg version 2.0.1+20111201

I can pull the same repo, but it doesn't work cloning it.
I've experienced it intermittently on OpenBSD since yesterday, on different hosts (i386/amd64), with mercurial 2.0.

pulling from http://hg.mozilla.org/mozilla-central/
searching for changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@27a7f197c6fc: unknown parent!
Occurs for me unless I use ssh rather than http.
This is also happening on the Thunderbird trunk mac boxes:

http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTrunk

I suspect they are using a recent version of hg, but I don't know the exact version. The linux boxes are definitely on something like 1.3.1 and aren't seeing this problem.

When I had issues the other day, 1.8.1 could pull fine but not 1.9 or 2.0.2.

Raising issue to major as this is affecting builders.
Severity: normal → major
(In reply to Ed Morley [:edmorley] from comment #10)
> Occurs for me unless I use ssh rather than http.
Thanks for the tip! I've been able to update comm-central just fine when I've switched from http to ssh.
Assignee: server-ops → mburns
I'll be working on these errors today..
Assignee: mburns → cshields
I can confirm that this is probably caused by upgrading mercurial. I just upgraded (using the standard Ubuntu repositories, to version 2.0.2), and since the upgrade I get this error reliably....

I can reproduce, so let me know if you need more information.
Using hg version 1.9.1.

Pulling from comm-central:
  hg pull -R .\\.

pulling from http://hg.mozilla.org/comm-central
searching for changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@25f87dd2453f: unknown parent!

So while the hash isn't the same, the error is similar.
Using TortoiseHg 2.2.2 (with Mercurial 2.0.2)

I'll get also
abort: 00changelog.i@25f87dd2453f: unknown parent!

With ssh it works.
(In reply to Bas Hickendorff from comment #14)
> I can confirm that this is probably caused by upgrading mercurial. I just
> upgraded (using the standard Ubuntu repositories, to version 2.0.2), and
> since the upgrade I get this error reliably....
> 
> I can reproduce, so let me know if you need more information.

Thanks, this was helpful.

I have not been able to reproduce at home but I'm skipping a couple of steps in the stack.  I upgraded hg on a colo box outside of the mozilla network and can now reproduce this.

No answers yet - but we are narrowing down where the problem lies.
I've made a couple of changes that I hope will fix this problem, but in doing so I've cleared the cache which means I lose my "known-broke" state.

That said, if anyone runs into this again please note the bug of what repo broke.  I'll be keeping an eye on things throughout the day but the only way I can tell if we are still having these issues are from user reports.
spoke too soon..  

hg clone http://hg.mozilla.org/mozilla-central
destination directory: mozilla-central
requesting all changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@da994c67e370: unknown parent!
Does anybody get Python backtraces? http://mercurial.selenic.com/bts/issue3204
Thanks for opening that issue, Stefan..   I think this is a combination of the way that newer hg combinations use http to send requests, and our use of varnish in the middle.

I've made another change and while so far I'm not able to reproduce the problem, I'm looking for more data and more people to "try again".
I just made an attempt to clone mozilla-central (http and https) and the problem is still there. This is with 2.0.1
Severity: major → normal
Severity: normal → major
I ran into this yesterday after installing mozilla-build 1.6 on a notebook (win7) and trying to check out comm-central. Today I still get the error:

$ hg clone http://hg.mozilla.org/comm-central
destination directory: comm-central
requesting all changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@49f1b07d5c78: unknown parent!
Cloning comm-central appears to work for me now, but I get the error when trying to clone mozilla-central.
FYIC:\mozilla-build>start-msvc10
"Mozilla tools directory: C:\mozilla-build\"
Visual C++ 10 Express directory: C:\Program Files (x86)\Microsoft Visual Studio
10.0\VC\
Windows SDK directory: C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\
Windows SDK version: 7.0A
Setting environment for using Microsoft Visual Studio 2010 x86 tools.
Mozilla build environment: MSVC version 10.

Master@MARKSLAPTOP ~
$ hg version
Mercurial Distributed SCM (version 1.9.1)
(see http://mercurial.selenic.com for more information)

Copyright (C) 2005-2011 Matt Mackall and others
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Master@MARKSLAPTOP ~
$ hg clone http://hg.mozilla.org/mozilla-central
destination directory: mozilla-central
requesting all changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@742d5f9f284d: unknown parent!

Master@MARKSLAPTOP ~
$
Getting this cloning m-c on Linux. Cloning to a machine on the build network, autoland-staging01.

$ hg clone https://hg.mozilla.org/mozilla-central
warning: hg.mozilla.org certificate with fingerprint 10:78:e8:57:2d:95:de:7c:de:90:bd:22:e1:38:17:67:c5:a7:9c:14 not verified (check hostfingerprints or web.cacerts config setting)
destination directory: mozilla-central
requesting all changes
adding changesets
transaction abort!
rollback completed
abort: 00changelog.i@742d5f9f284d: unknown parent!
Thanks for the additional reports.  We are busy trying to build a way around the current caching situation that is causing this.
We determined the problem to be in varnish which was sitting in front of hg.  Varnish caused multiple issues (not just this cache problem) so we worked a way around it.  With that, this error should not come up again unless we need to revert to the old way.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.