Last Comment Bug 718257 - Syntax error breaks add-on install restart doorhanger
: Syntax error breaks add-on install restart doorhanger
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: Firefox 12
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-14 21:17 PST by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-03-07 05:00 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
verified
11+


Attachments
patch (1.15 KB, patch)
2012-01-14 21:17 PST, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2012-01-14 21:17:01 PST
Created attachment 588710 [details] [diff] [review]
patch

Bug 717904 shows a bug in the restart process for add-on installation. A syntax error was breaking the display of the restart doorhanger. With this simple patch the doorhanger appears and will restart the app, if used.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-15 08:52:21 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/fbf07f7e8c93
Comment 2 Justin Wood (:Callek) 2012-01-16 19:31:30 PST
https://hg.mozilla.org/mozilla-central/rev/fbf07f7e8c93
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 13:03:20 PST
Comment on attachment 588710 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
addon restart door hanger is broken
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
none, fixes typo
Comment 4 Alex Keybl [:akeybl] 2012-01-20 13:05:39 PST
Comment on attachment 588710 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 13:43:42 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/24cb0e50df85
Comment 6 Paul Feher 2012-03-07 05:00:05 PST
Verified fixed on:
Nightly Fennec 13.0a1 (2012-03-06)
Device: HTC Desire Z
OS: Android 2.3.3

Note You need to log in before you can comment on or make changes to this bug.