Last Comment Bug 718281 - Hide Tilt outro transition in a pref
: Hide Tilt outro transition in a pref
Status: RESOLVED FIXED
[tilt][fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on: 712096
Blocks: 715647
  Show dependency treegraph
 
Reported: 2012-01-15 05:48 PST by Victor Porof [:vporof][:vp]
Modified: 2012-01-28 16:16 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (3.34 KB, patch)
2012-01-15 06:08 PST, Victor Porof [:vporof][:vp]
no flags Details | Diff | Review
v2 (3.34 KB, patch)
2012-01-15 11:35 PST, Victor Porof [:vporof][:vp]
no flags Details | Diff | Review
v3 (2.28 KB, patch)
2012-01-15 23:13 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Review

Description Victor Porof [:vporof][:vp] 2012-01-15 05:48:20 PST
Transition added by bug 712096. The animation itself may be annoying in some cases so it may be a good idea to have it disabled and hidden by default under a pref.
Comment 1 Victor Porof [:vporof][:vp] 2012-01-15 05:57:31 PST
Also, as long as we're adding an outro transition pref, we should also add an intro transition pref.
Comment 2 Victor Porof [:vporof][:vp] 2012-01-15 06:08:12 PST
Created attachment 588734 [details] [diff] [review]
v1
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2012-01-15 06:42:54 PST
I think we should show the transitions by default. If the speed of them is annoying, we can make it faster or slower.
Comment 4 Victor Porof [:vporof][:vp] 2012-01-15 07:01:53 PST
Here's a use case:

I open Tilt with an element at position (0, 0) selected. I pan down and select an element at position (0, n). Then I pan the camera back up. (I personally find myself in this case).

Suppose n > 2000 (or even a smaller number). If the closing animation is really fast, then it would be annoying (too choppy/jumpy). If it's slower, it would be counter productive.

What do you think?
Comment 5 Victor Porof [:vporof][:vp] 2012-01-15 11:35:21 PST
Created attachment 588759 [details] [diff] [review]
v2

Ok, talked to some people and it seems everyone wants an outro animation :)
I give in. Rob, what do you think?
Comment 6 Victor Porof [:vporof][:vp] 2012-01-15 23:13:24 PST
Created attachment 588816 [details] [diff] [review]
v3

Cleaned up, rebased on 712096.
Comment 7 Rob Campbell [:rc] (:robcee) 2012-01-16 11:02:43 PST
yes, I think a matching, closing transition is definitely nice to have and adds to the seamlessness of the visualization. Adding a pref to hide these things is fine, as long as they are enabled by default. Will review in greater depth forthwith.
Comment 8 Rob Campbell [:rc] (:robcee) 2012-01-19 13:27:08 PST
Comment on attachment 588816 [details] [diff] [review]
v3

sure thing!
Comment 9 Rob Campbell [:rc] (:robcee) 2012-01-20 10:47:37 PST
https://hg.mozilla.org/integration/fx-team/rev/ca5b6d4d1892
Comment 10 Rob Campbell [:rc] (:robcee) 2012-01-21 07:38:42 PST
https://hg.mozilla.org/mozilla-central/rev/ca5b6d4d1892
Comment 11 Rob Campbell [:rc] (:robcee) 2012-01-27 07:46:12 PST
Comment on attachment 588816 [details] [diff] [review]
v3

[Approval Request Comment]
Regression caused by (bug #): new feature
User impact if declined: Won't be able to turn off outro transitions with a preference.
Testing completed (on m-c, etc.): on mc.
Risk to taking this patch (and alternatives if risky): Minimal. In fact, this patch makes it possible to disable a feature we may want.

Note You need to log in before you can comment on or make changes to this bug.