Last Comment Bug 718303 - Tilt intro and outro transitions aren't very precise when page is zoomed
: Tilt intro and outro transitions aren't very precise when page is zoomed
Status: RESOLVED FIXED
[tilt]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on: 715647
Blocks: 718425
  Show dependency treegraph
 
Reported: 2012-01-15 09:11 PST by Victor Porof [:vporof][:vp]
Modified: 2012-01-28 16:17 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (12.52 KB, patch)
2012-01-15 11:30 PST, Victor Porof [:vporof][:vp]
no flags Details | Diff | Review
v2 (2.63 KB, patch)
2012-01-15 23:15 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Review

Description Victor Porof [:vporof][:vp] 2012-01-15 09:11:49 PST

    
Comment 1 Victor Porof [:vporof][:vp] 2012-01-15 11:30:57 PST
Created attachment 588757 [details] [diff] [review]
v1

Changes are backed up by existing tests. For the rest of the stuff in the patch, it's mostly about visual changes.
Comment 2 Victor Porof [:vporof][:vp] 2012-01-15 23:15:13 PST
Created attachment 588818 [details] [diff] [review]
v2

Cleaned up, try is green.
https://tbpl.mozilla.org/?tree=Try&rev=99f836e9fef1
Comment 3 Rob Campbell [:rc] (:robcee) 2012-01-20 09:27:21 PST
Comment on attachment 588818 [details] [diff] [review]
v2

looks good
Comment 4 Dão Gottwald [:dao] 2012-01-20 09:41:16 PST
The right and accurate way to get the zoom ratio is nsIDOMWindowUtils::screenPixelsPerCSSPixel.
Comment 5 Paul Rouget [:paul] 2012-01-20 09:50:03 PST
This highlighter as a `zoom` property that uses `nsIDOMWindowUtils::screenPixelsPerCSSPixel`.

Just use highlighter.zoom.

http://mxr.mozilla.org/mozilla-central/source/browser/devtools/highlighter/highlighter.jsm#626
Comment 6 Victor Porof [:vporof][:vp] 2012-01-20 09:59:20 PST
Yes, we can and should use this. Follow-up bug to avoid rebasing 7 other patches :)
Thanks Paul!
Comment 7 Victor Porof [:vporof][:vp] 2012-01-20 10:05:12 PST
Bug 719877.
Comment 8 Rob Campbell [:rc] (:robcee) 2012-01-25 11:46:12 PST
https://hg.mozilla.org/integration/fx-team/rev/586448c078ef
Comment 9 Tim Taubert [:ttaubert] 2012-01-25 23:57:10 PST
https://hg.mozilla.org/mozilla-central/rev/586448c078ef
Comment 10 Rob Campbell [:rc] (:robcee) 2012-01-27 07:38:02 PST
Comment on attachment 588818 [details] [diff] [review]
v2

[Approval Request Comment]
Regression caused by (bug #): New feature
User impact if declined: Intro and outro transitions may be inaccurate on zoomed pages.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Low risk. Small patch.
Comment 11 Rob Campbell [:rc] (:robcee) 2012-01-28 09:46:34 PST
bugzilla :|

Note You need to log in before you can comment on or make changes to this bug.