Closed Bug 718310 Opened 8 years ago Closed 8 years ago

Port |Bug 526998 - Implement F2 keyboard shortcut for renaming focused attachments when composing (on Windows and Unix)|

Categories

(SeaMonkey :: MailNews: Composition, enhancement)

x86_64
Windows 7
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.9

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Details

Attachments

(1 file)

SSIA. Differences to what they did for TB:

* TB uses preprocessing, I made use of our platformMailnewsOverlay to exclude Mac
* they rewrote the whole controllers, I sticked to what we always do
* I didn't add Rename Attachment to the menus or change any l10n
* I didn't remove the onkeypress line from the attachmentlist (should I?)
Attachment #588751 - Flags: superreview?(neil)
Attachment #588751 - Flags: review?(mnyromyr)
(In reply to Jens Hatlak from comment #0)
> * TB uses preprocessing, I made use of our platformMailnewsOverlay to exclude Mac
Of course :-)

> * they rewrote the whole controllers, I sticked to what we always do
If we were to go with anything like their system, I would actually have a JS object that converts from the command-object-object to the controller object, rather than duplicating the supports/do/isCommandEnabled logic.

> * I didn't add Rename Attachment to the menus or change any l10n
> * I didn't remove the onkeypress line from the attachmentlist (should I?)
Doesn't seem relevant to the keyboard shortcut, so followup bugs, perhaps.
The controller refactoring isn't really relevant either, but it was needed anyway to fix pressing delete with the From field focused ;-)
Attachment #588751 - Flags: superreview?(neil) → superreview+
(In reply to Philip Chee from comment #2)
> > Bug 718310 - Port |Bug 526998
> Bug 526998 got backed out.

Yeah I know. We don't have test that was failing (and needed to be adapted) and I didn't introduce new strings, so all is well. :-)
Comment on attachment 588751 [details] [diff] [review]
patch [Checkin: Comment 5]

>+var attachmentBucketController =

Since controllers are global objects, (new) controllers' names should have the g prefix, i.e. gAttachmentBucketController.

r=me with that.
Attachment #588751 - Flags: review?(mnyromyr) → review+
Comment on attachment 588751 [details] [diff] [review]
patch [Checkin: Comment 5]

http://hg.mozilla.org/comm-central/rev/e51b6e8ee03b
Attachment #588751 - Attachment description: patch → patch [Checkin: Comment 5]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.9
You need to log in before you can comment on or make changes to this bug.