Last Comment Bug 718357 - Do not use new console when browser restarts on Windows
: Do not use new console when browser restarts on Windows
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Brian R. Bondy [:bbondy]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-15 19:49 PST by Brian R. Bondy [:bbondy]
Modified: 2012-01-21 07:12 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1. (2.26 KB, patch)
2012-01-15 19:55 PST, Brian R. Bondy [:bbondy]
jmathies: review+
Details | Diff | Splinter Review

Description Brian R. Bondy [:bbondy] 2012-01-15 19:49:26 PST
A new console is opened whenever the browser restarts in debug mode, such as after installing an add-on.

It should use the same console instead. 

This was introduced after the service was landed, in particular from bug 711692.  It was added originally because it was suspected it would help a callback app in use error that happened intermittently, but it wasn't needed after all.  The side effects were not all fully understood at the time of adding.
Comment 1 Brian R. Bondy [:bbondy] 2012-01-15 19:55:46 PST
Created attachment 588806 [details] [diff] [review]
Patch v1.

This is where it was added by the way:
https://bugzilla.mozilla.org/page.cgi?id=splinter.html&bug=711692&attachment=585742

The CreateProcessAsUserW call is not currently used but should be consistent with the CreateProcessW one.
Comment 2 Brian R. Bondy [:bbondy] 2012-01-19 13:31:56 PST
Thanks for the review Jim.

Pushed to inbound.
http://hg.mozilla.org/integration/mozilla-inbound/rev/d0eed1fd4272
Comment 3 Ed Morley [:emorley] 2012-01-21 07:12:19 PST
https://hg.mozilla.org/mozilla-central/rev/d0eed1fd4272

Note You need to log in before you can comment on or make changes to this bug.