configure.in: remove useless SANITY_CHECKING_FEATURE and XCB_SURFACE_FEATURE

VERIFIED FIXED in mozilla13

Status

()

Core
Graphics
--
trivial
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: capella)

Tracking

Trunk
mozilla13
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
(Follow-up to bug 513702.)

Afaict, these 2 variables are (now?) unused.

http://mxr.mozilla.org/mozilla-central/search?string=SANITY_CHECKING_FEATURE&case=1&find=%2Fconfigure.in%24
{
/configure.in
    * line 8115 -- SANITY_CHECKING_FEATURE="#define CAIRO_DO_SANITY_CHECKING 1"
    * line 8117 -- SANITY_CHECKING_FEATURE="#undef CAIRO_DO_SANITY_CHECKING"
}
http://mxr.mozilla.org/mozilla-central/search?string=CAIRO_DO_SANITY_CHECKING&case=1&find=%2Fconfigure.in%24
Same result.

http://mxr.mozilla.org/mozilla-central/search?string=XCB_SURFACE_FEATURE&case=1&find=\.in%24
{
/configure.in
    * line 8127 -- AC_SUBST(XCB_SURFACE_FEATURE)
/gfx/cairo/cairo/src/cairo-features.h.in
    * line 72 -- @XCB_SURFACE_FEATURE@
}
Flags: in-testsuite-
(Assignee)

Comment 1

5 years ago
Created attachment 596671 [details] [diff] [review]
Remove obsolete variables
Attachment #596671 - Flags: feedback?(sgautherie.bz)
(Assignee)

Comment 2

5 years ago
   Coded, tested / re-built with mozilla-central pull -u ... all seems to work.
(Reporter)

Updated

5 years ago
Attachment #596671 - Attachment is patch: true
(Reporter)

Updated

5 years ago
Attachment #596671 - Flags: review?(jmuizelaar)
Attachment #596671 - Flags: feedback?(sgautherie.bz)
Attachment #596671 - Flags: feedback+
(Reporter)

Updated

5 years ago
Assignee: nobody → markcapella
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla13
(Assignee)

Comment 3

5 years ago
   Ping jmuizelaar for the review? ...
(Assignee)

Comment 4

5 years ago
Serge: we're still waiting on the review ... is there a follow-up plan to move this forward?
(Reporter)

Comment 5

5 years ago
(In reply to Mark Capella [:capella] from comment #4)
> Serge: we're still waiting on the review ... is there a follow-up plan to
> move this forward?

I can't do more than f+.
I guessed a reviewer by default: if that doesn't work, you may try differently.
But I already spend too much time trying to get reviews for my own patches :-/
(Assignee)

Updated

5 years ago
Attachment #596671 - Flags: review?(jmuizelaar) → review?(khuey)
Attachment #596671 - Flags: review?(khuey) → review+
(Assignee)

Updated

5 years ago
Whiteboard: [good first bug] → [autoland]

Updated

5 years ago
Whiteboard: [autoland] → [autoland-in-queue]

Comment 6

5 years ago
Autoland Patchset:
	Patches: 596671
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=eac9ccf85315
Try run started, revision eac9ccf85315. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=eac9ccf85315

Comment 7

5 years ago
Try run for eac9ccf85315 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=eac9ccf85315
Results (out of 218 total builds):
    success: 180
    warnings: 24
    failure: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-eac9ccf85315

Updated

5 years ago
Whiteboard: [autoland-in-queue]
(Assignee)

Updated

5 years ago
Whiteboard: checkin-needed
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: checkin-needed
(Reporter)

Comment 8

5 years ago
(In reply to Mozilla RelEng Bot from comment #7)
>     failure: 14

You should mark (and comment about) the failures before asking for c-n:

Some are from ignored builds and you shouldn't care about them.
https://tbpl.mozilla.org/?tree=Try&rev=eac9ccf85315&noignore=1

The unignored ones, you should check whether they are (known) random, or (filed) regression.
Running failed builds another time may help, if in doubt.
Keywords: checkin-needed
(Assignee)

Updated

5 years ago
Whiteboard: [autoland]

Updated

5 years ago
Whiteboard: [autoland] → [autoland-in-queue]

Comment 9

5 years ago
Autoland Patchset:
	Patches: 596671
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=0054ee0029bb
Try run started, revision 0054ee0029bb. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=0054ee0029bb
(In reply to Serge Gautherie (:sgautherie) from comment #8)
> (In reply to Mozilla RelEng Bot from comment #7)
> >     failure: 14
> 
> You should mark (and comment about) the failures before asking for c-n:
> 
> Some are from ignored builds and you shouldn't care about them.
> https://tbpl.mozilla.org/?tree=Try&rev=eac9ccf85315&noignore=1
> 
> The unignored ones, you should check whether they are (known) random, or
> (filed) regression.
> Running failed builds another time may help, if in doubt.

That actually looks like a pretty clean tryserver run; I don't see any reason this shouldn't land.
(Assignee)

Comment 11

5 years ago
Not sure why extra message show up with ignore=1 option, all seem to involve jetpack ... results from   https://tbpl.mozilla.org/?tree=Try&rev=eac9ccf85315 only show a few warnings that didnt seem to involve my changes.

I posted another TRY in either case.

Comment 12

5 years ago
Try run for 0054ee0029bb is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0054ee0029bb
Results (out of 220 total builds):
    exception: 6
    success: 175
    warnings: 25
    failure: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-0054ee0029bb

Updated

5 years ago
Whiteboard: [autoland-in-queue]
(Assignee)

Comment 13

5 years ago
With comment #10 and re-review of warnings in https://tbpl.mozilla.org/?tree=Try&rev=0054ee0029bb I'm again asking for check-in.
Keywords: checkin-needed
(Reporter)

Comment 14

5 years ago
(In reply to Mark Capella [:capella] from comment #11)

> Not sure why extra message show up with ignore=1 option

These builds are "hidden" by default, until they are fixed.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5dd8529c9346
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5dd8529c9346
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

5 years ago
V.Fixed, per MXR.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.