mapi problem after account delete

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
3 months ago

People

(Reporter: mraz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111228084940

Steps to reproduce:

I have two account pop3 and imap. After i was pop3 account delete, I was unable to send mail from MS Word.


Actual results:

thunderbird was open but new message with attachment was not created.


Expected results:

Problem is in configuration json file in setting 

user_pref("mail.account.account2.identities", "idxxx");
I was this and other settings with account2 to account1 and sending starting work

Comment 1

7 years ago
Do you say that Outlook trhough MAPI was still trying to send via nonexistent account1 and failed?

The correct behaviour would be to choose the first existing (default) account in TB?
Component: General → Preferences
QA Contact: general → preferences
(Reporter)

Comment 2

7 years ago
I was say, that Thunderbird not set default account after delete one.
after delete the setting user_pref("mail.account.account1.identities", "id1"); was dissapear, but second accound not set as default for cooperating with MAPI
(Reporter)

Comment 3

7 years ago
Perhaps I should be more precise. I originally had two accounts configured on TB, one pop (account1)  and one imap (account2) . After removing the pop account (it was the default account), I was no more able to send e-mails from MS Office. I guess that the problem resided in that the deleted account1 still remained in the json configuration file: user_pref("mail.account.account2.identities", "idxxx"); Having replaced  account2 by account1 there, sending emails from MS Word works normally. 
So, I guess that TB should, when deleting the default account, change the json entry automatically.

Comment 4

7 years ago
What is "idxxx" in your case? What was the real value?
Component: Preferences → Simple MAPI
Product: Thunderbird → MailNews Core
QA Contact: preferences → simple-mapi
(Reporter)

Comment 5

7 years ago
on one computer is 1964 on other is it 3514 on another one is it somthing else

example of wrong configuration
user_pref("mail.account.account2.identities", "id3514");
user_pref("mail.account.account1.server", "server1");
user_pref("mail.account.account2.server", "server2");
user_pref("mail.account.account3.server", "server3");
user_pref("mail.accountmanager.accounts", "account1,account2,account3");
user_pref("mail.accountmanager.defaultaccount", "account1");
user_pref("mail.accountmanager.localfoldersserver", "server1");

Comment 6

7 years ago
That is interesting, usually the ids are numbered from 1.
Anyway, you then should have prefs like mail.identity.id3514.* .

But the real problem probably is that somewhere (in Word, or in Windows registry (try to find out where it is defined that MAPI should use Thunderbird)), it is bound to account1, which no longer exists. Can you find that spot? I am just guessing here, maybe the place you find will only be bound to Thunderbird, not to specific account in it. Then it would be a problem in TB.
(Reporter)

Comment 7

7 years ago
I was imported mail from outlok that was two accounts pop3 and acount for exchange
after importing mails to TB i was in TB add imap account (gmail) and compy all mesages from import folder to new imap account.
why is id3514 i dont know.

I dont understand why default account is account1 - user_pref("mail.accountmanager.defaultaccount", "account1"); - because account1 not exist
Mayby should be help change only this setting, i dont try it.

Comment 8

7 years ago
Great, you may have found it.
Try to change it to account2.
But the you must have the preferences set to contain account2 (not account1):
user_pref("mail.account.account2.identities", "idxxx");
etc.
(Reporter)

Comment 9

7 years ago
I try it on other PC it works when i change to account2, but TB should change default account automaticaly or disallow to delete default account.

Comment 10

7 years ago
Yes exactly. It should update that pref automatically to some other account.

The problem is, it does that for me. I had about 5 accounts in my test setup (TB12, Win XP). I set account5 as my default account. When I deleted it, TB automatically changed mail.accountmanager.defaultaccount to account1. So I do not know why that didn't happen in your setup.
(Reporter)

Comment 11

7 years ago
I have TB9.  TB should have test on startup if default account exist or in Mapi Module which could be show warning, that default account is not set corectly.

Comment 12

7 years ago
Yes.
Two questions to be sure:
-Where do you set MAPI to use Thunderbird?
-How did you delete the account from Thunderbird?
(Reporter)

Comment 13

7 years ago
-I use start menu> all programs > Default programs (i have localised version of windows i dont know how it is exactly call in en)
-Because i migrating all mails to gmail on 30 PC. (I dont remember if i first remove pop3 and then create imap account or vice versa) this proble i was found on 5 PC.
(Reporter)

Comment 14

7 years ago
I forget that on some PC i was deleting folder mail with local folders by hand because import from outlook was fault and deleting through TB was so slow.

Comment 15

7 years ago
(In reply to Peter Mráz from comment #13)
> -Because i migrating all mails to gmail on 30 PC. (I dont remember if i
> first remove pop3 and then create imap account or vice versa) this proble i
> was found on 5 PC.

I mean if you removed the account normally from inside Thunderbird Account manager.
(Reporter)

Comment 16

7 years ago
Yes
(In reply to :aceman from comment #12)

> -Where do you set MAPI to use Thunderbird?

It's done by the installer and we load a library for that.

Franck I've cced you to a few new mapi issues in the last two days could you look at them please ?
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
(In reply to :aceman from comment #10)
> Yes exactly. It should update that pref automatically to some other account.
> 
> The problem is, it does that for me. I had about 5 accounts in my test setup
> (TB12, Win XP). I set account5 as my default account. When I deleted it, TB
> automatically changed mail.accountmanager.defaultaccount to account1. So I
> do not know why that didn't happen in your setup.

Is there a bug for this?
Flags: needinfo?(acelists)

Comment 20

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #19)
> > The problem is, it does that for me. I had about 5 accounts in my test setup
> > (TB12, Win XP). I set account5 as my default account. When I deleted it, TB
> > automatically changed mail.accountmanager.defaultaccount to account1. So I
> > do not know why that didn't happen in your setup.
> 
> Is there a bug for this?

What exactly?
Flags: needinfo?(acelists)
> What exactly?

For whatever shouldn't be happening when an account is deleted.
Or there isn't really a bug here?

(I'm not following the convseration, hence the question)

Comment 22

2 years ago
After an account was deleted, a new default account should be chosen. I know of no bug that it doesn't happen. Only this one.
Reporter, this probably shouldn't happen anymore. If you still see it then please comment in the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.