Touch events don't get forwarded to the web page

RESOLVED DUPLICATE of bug 603008

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 603008
6 years ago
6 years ago

People

(Reporter: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org), Unassigned)

Tracking

({regression})

Trunk
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 588837 [details]
Testcase

I've noticed that some mobile games work fine on Fennec Beta (Firefox 10 build 20120104) but not on Aurora (Firefox 11.0a2 build 20120115) or Nightly (Firefox 12.0a1 build 20120115). It seems that touch events simply aren't being forwarded to the web page any more. Steps to reproduce:

* Open the attached web page in Fennec.
* Touch anywhere on the page.

Expected result:

A message saying "touch" opens (in Firefox 10).

Actual result:

Nothing happens, the page doesn't receive the event (in Firefox 11/12, tested on Samsung Galaxy S II)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603008
Mark, are you sure it's a duplicate? I've seen that bug but it appears to be a platform issue - the platform simply doesn't support multitouch. Here we have something however that used to work (singletouch I guess?) but broke with the move to the native UI.
(In reply to Wladimir Palant from comment #2)
> Mark, are you sure it's a duplicate? I've seen that bug but it appears to be
> a platform issue - the platform simply doesn't support multitouch. Here we
> have something however that used to work (singletouch I guess?) but broke
> with the move to the native UI.

I am mostly certain that the code in bug 603008 is needed to un-break the single-touch behavior in the new native UI as well.
Required is a bit of a stretch. We could potentially forward all touches to content using the message passing system and then forward the single touch (or even multi touch) to content. That's similar to what we did on XUL Fennec.

But at this point, 603008 will take less time to fix (I think its done) than to do that (and to make the dispatching somewhat match the touch events spec).
You need to log in before you can comment on or make changes to this bug.