Closed Bug 718392 Opened 8 years ago Closed 8 years ago

[Mac] Restore non-highlight when hovering menus in content menubars

Categories

(Toolkit :: Themes, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla12

People

(Reporter: stefanh, Assigned: stefanh)

References

Details

(Keywords: regression, Whiteboard: [inbound])

Attachments

(1 file, 1 obsolete file)

The patch in bug 595201 made XUL menus in content menubars highlight when you hover them. This is not the default behavior on Mac (and the bg-color is wrong).
(never mind what I said about the bg-color, there shouldn't be any)
Attached patch Restore old behavior (obsolete) — Splinter Review
What they did in bug 632989, should work here too. But I don't think we want that (it would for example affect menus in editable menulists)
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #588838 - Flags: review?(dao)
Comment on attachment 588838 [details] [diff] [review]
Restore old behavior

>+  background-color: inherit;

Why inherit? I think you want transparent here.
(In reply to Dão Gottwald [:dao] from comment #3)
> Comment on attachment 588838 [details] [diff] [review]
> Restore old behavior
> 
> >+  background-color: inherit;
> 
> Why inherit? I think you want transparent here.

Ah, yes, true (inherit works because the menubar has a transparent bg, but you're right).
Attachment #588838 - Attachment is obsolete: true
Attachment #588838 - Flags: review?(dao)
Attachment #588852 - Flags: review?(dao)
Attachment #588852 - Flags: review?(dao) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/098a5b456aef
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla12
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whoops...
Status: REOPENED → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/098a5b456aef
Status: ASSIGNED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.