Callback application does not relaunch on some limited user account WinXP installs after app update

VERIFIED FIXED in mozilla12

Status

()

defect
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

unspecified
mozilla12
x86_64
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

On a Windows XP machine of Simona (QA), the callback application (firefox) does not restart after performing updates.
On the same machine with an admin account, the callback does restart.
The limited user account user has Nightly installed into the app user data.
This is without the service installed, and I believe the problem on this particular XP machine happened before the service code landed as well.
This particular machine has 6-10 different Firefox installations on it as well.

This bug is to figure out what the problem is via remote login and to fix the bug.

I did one login so far and noticed that the XRE_UPDATE_ROOT_DIR cannot be obtained from the directory service.
I also noticed that the limited user account had a space in it.
I tried to reproduce this locally by manually forcing the XRE_UPDATE_ROOT_DIR directory fetching to fail and to create an account with a space in it, but I could not reproduce.

I will login again tomorrow to investigate more.
I did more debugging on
sorry the last message submitted accidentally when I added some people to the CC list. 

I did more debugging today on Simona's XP machine which is a limited user account.  I found out the problem is because of the permissions we drop in Bug 708778.  

For some reason one of these permissions is needed on Simona's machine, but not on my XP machine which is also running as a limited user account.  

We ran out of time today, but tomorrow morning I'll verify the exact permissions that is causing the problem and I'll no longer disable that permissions since it is needed.
Depends on: 708778
Posted patch Patch v1.Splinter Review
This is the problem Simona reported on one of the XP machines where testing was done.  It was reproducible only once the service landed. I verified that this fixes it after testing and uploading a couple dozen builds to figure out exactly what the problem was.
Attachment #589526 - Flags: review?(robert.bugzilla)
Comment on attachment 589526 [details] [diff] [review]
Patch v1.

Please inform imelven and / or bsmith of this change.
Attachment #589526 - Flags: review?(robert.bugzilla) → review+
imelven, bsmith please let me know if you have any objections to this patch.
(In reply to Brian R. Bondy [:bbondy] from comment #5)
> imelven, bsmith please let me know if you have any objections to this patch.

none from me - this isn't one of the most dangerous privileges thankfully. thanks for the comment in the patch, it's a very good explanation.
https://hg.mozilla.org/mozilla-central/rev/847feb303673
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120126 Firefox/12.0a1

Verified on Windows XP that Nightly automatically restarts after performing an update when logged in with a limited user account

Setting status of this bug to VERIFIED FIXED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.