Closed Bug 718713 Opened 12 years ago Closed 12 years ago

FATAL EXCEPTION: ActivityNotFoundException: Unable to find explicit activity class {org.mozilla.gecko/org.mozilla.gecko.sync.setup.activities.SetupSyncActivity}

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

ARM
Android
defect
Not set
critical

Tracking

(firefox12 affected)

RESOLVED DUPLICATE of bug 718703
Tracking Status
firefox12 --- affected

People

(Reporter: aaronmt, Unassigned)

Details

(Keywords: crash, reproducible, Whiteboard: sync)

W/dalvikvm( 6566): threadid=1: thread exiting with uncaught exception (group=0x40a4e1f8)
E/AndroidRuntime( 6566): FATAL EXCEPTION: main
E/AndroidRuntime( 6566): android.content.ActivityNotFoundException: Unable to find explicit activity class {org.mozilla.gecko/org.mozilla.gecko.sync.setup.activities.SetupSyncActivity}; have you declared this activity in your AndroidManifest.xml?
E/AndroidRuntime( 6566): 	at android.app.Instrumentation.checkStartActivityResult(Instrumentation.java:1508)
E/AndroidRuntime( 6566): 	at android.app.Instrumentation.execStartActivity(Instrumentation.java:1384)
E/AndroidRuntime( 6566): 	at android.app.ContextImpl.startActivity(ContextImpl.java:852)
E/AndroidRuntime( 6566): 	at android.preference.Preference.performClick(Preference.java:957)
E/AndroidRuntime( 6566): 	at android.preference.PreferenceScreen.onItemClick(PreferenceScreen.java:202)
E/AndroidRuntime( 6566): 	at android.widget.AdapterView.performItemClick(AdapterView.java:292)
E/AndroidRuntime( 6566): 	at android.widget.AbsListView.performItemClick(AbsListView.java:1058)
E/AndroidRuntime( 6566): 	at android.widget.AbsListView$PerformClick.run(AbsListView.java:2514)
E/AndroidRuntime( 6566): 	at android.widget.AbsListView$1.run(AbsListView.java:3168)
E/AndroidRuntime( 6566): 	at android.os.Handler.handleCallback(Handler.java:605)
E/AndroidRuntime( 6566): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/AndroidRuntime( 6566): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime( 6566): 	at android.app.ActivityThread.main(ActivityThread.java:4424)
E/AndroidRuntime( 6566): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime( 6566): 	at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime( 6566): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
E/AndroidRuntime( 6566): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
E/AndroidRuntime( 6566): 	at dalvik.system.NativeStart.main(Native Method)
W/ActivityManager(  153):   Force finishing activity com.android.settings/.SubSettings
W/ActivityManager(  153): Activity pause timeout for ActivityRecord{416281d8 com.android.settings/.SubSettings}

STR:

1. Accounts and Sync Settings -> Pair a Device

--
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120117 Firefox/12.0a1 Fennec/12.0a1
Summary: ActivityNotFoundException: Unable to find explicit activity class {org.mozilla.gecko/org.mozilla.gecko.sync.setup.activities.SetupSyncActivity} → FATAL EXCEPTION: ActivityNotFoundException: Unable to find explicit activity class {org.mozilla.gecko/org.mozilla.gecko.sync.setup.activities.SetupSyncActivity}
I believe this is a dupe of bug 718703
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.