Last Comment Bug 718737 - Add a startup timeline event on nsDocShell::LoadURI
: Add a startup timeline event on nsDocShell::LoadURI
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 718738
  Show dependency treegraph
 
Reported: 2012-01-17 10:45 PST by Mike Hommey [:glandium]
Modified: 2012-01-22 23:05 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add a startup timeline event on the first nsDocShell::LoadURI for non about:blank content (3.68 KB, patch)
2012-01-18 01:35 PST, Mike Hommey [:glandium]
bzbarsky: review+
taras.mozilla: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-01-17 10:45:22 PST
We want to report, like we currently do for timestamps like main, sessionRestore, firstPaint, etc., the timestamp at which the first non about:blank uri is loaded.
Comment 1 Mike Hommey [:glandium] 2012-01-18 01:35:31 PST
Created attachment 589432 [details] [diff] [review]
Add a startup timeline event on the first nsDocShell::LoadURI for non about:blank content
Comment 2 Mike Hommey [:glandium] 2012-01-18 01:37:18 PST
Comment on attachment 589432 [details] [diff] [review]
Add a startup timeline event on the first nsDocShell::LoadURI for non about:blank content

Asking taras review for StartupTimeline changes (it appears gcc is stupid and doesn't realize it doesn't need to call PR_Now when the condition is not fulfilled).
Comment 3 Mike Hommey [:glandium] 2012-01-18 01:49:02 PST
There's a glitch, though: we're going to have noise in our telemetry data on android, because fennec doesn't load any non about:blank content when starting without an url (that is, when showing the non-content/native-android-ui about:home).
Comment 4 Mike Hommey [:glandium] 2012-01-18 02:22:27 PST
Interestingly, the startup timeline event is triggered at what seems a "normal" time when starting fennec without an url, so forget comment 3.
Comment 5 (dormant account) 2012-01-18 16:29:53 PST
Comment on attachment 589432 [details] [diff] [review]
Add a startup timeline event on the first nsDocShell::LoadURI for non about:blank content

I think this should work
Comment 6 Boris Zbarsky [:bz] 2012-01-18 18:56:08 PST
Comment on attachment 589432 [details] [diff] [review]
Add a startup timeline event on the first nsDocShell::LoadURI for non about:blank content

"mItemType == typeContent" has extra parens around it, and you're reinventing NS_IsAboutBlank.

r=me with those bits fixed.
Comment 8 Matt Brubeck (:mbrubeck) 2012-01-19 10:55:38 PST
https://hg.mozilla.org/mozilla-central/rev/ee34d8fb535d
Comment 9 Daniel Cater 2012-01-21 17:56:55 PST
Will this cause slightly bogus values for people who have about:blank as their homepage? It's going to be a small number of people, but I'm sure they exist (there used to be a button in preferences for it a few years ago).
Comment 10 Boris Zbarsky [:bz] 2012-01-22 04:30:14 PST
Probably.  I'm one of those people, certainly.  And there's still a preference for it.
Comment 11 Mike Hommey [:glandium] 2012-01-22 23:05:32 PST
Most definitely yes.

Note You need to log in before you can comment on or make changes to this bug.