Closed Bug 718765 Opened 8 years ago Closed 8 years ago

crash js::mjit::ImmutableSync::allocReg

Categories

(Firefox for Android :: General, defect, critical)

All
Linux
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: Pike, Unassigned)

References

()

Details

(Keywords: crash, reproducible, topcrash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-bfdabfc9-001e-497a-9428-1c1472120117 .
============================================================= 

This is a 100% reproducable crash on nightly on the web-facing entry page of http://www.spiegel.de/

I'm only seeing this today, so I think it's gotta be a regression in the last few days.
Loads on yesterday's build 20120116.  regression range between yesterday and today.
Keywords: reproducible
Whiteboard: [native-crash]
www.sunshine-live.de is another site to check.
Here is the Windows version of this crash (no STR, 5 crashes in 9.0.1 over the last four weeks): bp-93fa14f1-c45e-48f5-9a81-b0cc62120113
We have a suspicion that this was caused by bug 708303. I just backed it out. We should watch crashes to see if they go away.
It's #1 top crasher in 12.0a1.

(In reply to Mark Finkle (:mfinkle) from comment #6)
> We have a suspicion that this was caused by bug 708303. I just backed it
> out.
It will land in 12.0a1/20120119.
Keywords: topcrash
I was able to reproduce this issue on the latest Nightly build.

STR:
1. Go to news.google.com
2. Long tap on a news title and open it in a new tab
3. Switch to the new opened tab
4. Wait until the page is loaded

ER:
No crash should occur after step 4.

AR:
After step 4, Fennec crashes. Please see the attached crash log.
https://crash-stats.mozilla.com/report/index/bp-130f701d-daf3-4b4d-af45-d41982120119

Note:
This STR works just for this news so far: http://news.google.com/m/url?ei=R9gXT7HhBIOV8gPGTA&q=http://www.boston.com/news/nation/washington/articles/2012/01/19/a_qa_on_contested_internet_anti_piracy_bills/&site=news&usg=AFQjCNGGScnWr8qRxgAjse3W5ZAGYre5Pg


--
Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/20120118
Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Attached file crash log
(In reply to Naoki Hirata :nhirata from comment #8)
> Tinderbox Build : 
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=8637431&tree=Firefox
> http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-
> central-android/1326899412/
> 
> Site is painted bad, but it's no longer crashing with the tinderbox build.

Seem that's working fine on this tinderbox build.
I get this crash by visiting the following website: http://www.ubervu.com/
For those who can reproduce this crash reliably, can you test your STR in 12.0a1/20120119031105 where bug 708303 has been back out?
(In reply to Scoobidiver from comment #13)
> For those who can reproduce this crash reliably, can you test your STR in
> 12.0a1/20120119031105 where bug 708303 has been back out?

I can confirm that ubervu.com works on today's build of Firefox. Thanks!
Blocks: 708303
1/19/2012 build works for me.  Waiting to hear back from xti.
The latest crashes occurred in 12.0a1/20120118031059, so it's fixed by the backout of bug 708303:
https://crash-stats.mozilla.com/report/list?signature=js%3A%3Amjit%3A%3AImmutableSync%3A%3AallocReg
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
(In reply to Naoki Hirata :nhirata from comment #15)
> 1/19/2012 build works for me.  Waiting to hear back from xti.

It works for me too, on the latest Nightly build. I will mark this bug as verified fixed.

--
Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/20120119
Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.