Closed Bug 718970 Opened 10 years ago Closed 10 years ago

Pinch zooming over images can be buggy

Categories

(Firefox for Android Graveyard :: General, defect, P4)

ARM
Android
defect

Tracking

(firefox13 verified, fennec+)

VERIFIED FIXED
Tracking Status
firefox13 --- verified
fennec + ---

People

(Reporter: martijn.martijn, Assigned: kats)

References

Details

(Keywords: testcase)

Attachments

(1 file)

Attached file testcase
See testcase, steps to reproduce:
- Put one finger (the thumb) down on the text ("some text")
- Put on finger down on the top image (the green box with blue border)
- Pinch zoom out
- Release both fingers
- Tap one time on the text

Expected result:
- Nothing happens

Actual result:
- Weird zooming out of the page at a level that should not exist permanently
I guess image might have their own mouse event capturing code or something that is triggering this bug.
Actually, I get this problem with without images too, see this video:
http://www.youtube.com/watch?v=ssD5IMFNS8g&context=C3a3ac4eADOEgsToPDskLnnSo54yWUW-B0hUhPJObG

I guess this has something to do with selection event capturing or something.
I've seen this occasionally too but haven't been able to reliably reproduce it. If you can do please attach logcat output.
Assignee: nobody → bugmail.mozilla
tracking-fennec: --- → ?
tracking-fennec: ? → +
Priority: -- → P4
After playing around with this a little bit, the only thing I could reliably reproduce (on the Galaxy Tab 10.1) was the canvas jumping unexpectedly if you do this:

1. Place one finger down on the page
2. Place one finger out the outside border of the device (the black area around the screen)
3. Drag the outside finger onto the main screen area

This causes a discontinuous jump and zoom of the page which should be fixed. I suspect that the cases you're describing might be a result of events specific to your device. I'll try on some other devices on Monday (hopefully) and see if I can get different behaviours.
So the issue I was seeing has been fixed with the ScaleGestureDetector rewrite (bug 706684). Please re-test on the latest nightly to see if the original issue is still happening. (If you're testing on an Android 2.2 device you'll need to wait for the new nightly that's being spun now so you get https://hg.mozilla.org/mozilla-central/rev/cd76470c9e6f as well, or use the debug build I uploaded to https://people.mozilla.com/~kgupta/tmp/0d5ad6a6f814.apk)
Yes, it seems to be fixed indeed. Marking fixed, thanks.

I was seeing this in a lot more places, so I'll keep an eye on it, but I think it's safe to say this is fixed, since it was quite easy for me to reproduce.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Verified fixed on:

Firefox 13.0a1 (2012-03-06)
20120306031101
http://hg.mozilla.org/mozilla-central/rev/7d0d1108a14e

--
Device: HTC Desire
OS: Android 2.2
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.