Last Comment Bug 718990 - Atk-based plugins to slot into our a11y tree stucks orca in some flash web pages.
: Atk-based plugins to slot into our a11y tree stucks orca in some flash web pa...
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All Linux
: -- normal (vote)
: mozilla12
Assigned To: Trevor Saunders (:tbsaunde)
:
: alexander :surkov
Mentors:
Depends on:
Blocks: 480317
  Show dependency treegraph
 
Reported: 2012-01-18 05:21 PST by Jignesh Kakadiya [:jhk]
Modified: 2012-01-27 10:53 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (32.78 KB, patch)
2012-01-18 05:48 PST, Jignesh Kakadiya [:jhk]
no flags Details | Diff | Splinter Review
patch (3.91 KB, patch)
2012-01-25 23:41 PST, Trevor Saunders (:tbsaunde)
surkov.alexander: review+
Details | Diff | Splinter Review

Description Jignesh Kakadiya [:jhk] 2012-01-18 05:21:35 PST
By Looking at Bug 665820 comment 3. It observed that implementation of atk-based plugins in Bug 480317 leads orca to stuck in some of the flash based web pages.
Comment 1 Jignesh Kakadiya [:jhk] 2012-01-18 05:48:40 PST
Created attachment 589478 [details] [diff] [review]
Patch
Comment 2 Ginn Chen 2012-01-18 06:38:20 PST
I've no access to Bug 665820, but it looks like you're simply backout Bug 480317.
Comment 3 Jignesh Kakadiya [:jhk] 2012-01-18 07:14:59 PST
(In reply to Ginn Chen from comment #2)
> I've no access to Bug 665820, but it looks like you're simply backout Bug
> 480317.

Sorry! here is the link. https://bugzilla.gnome.org/show_bug.cgi?id=665820. 
Yes this is not final patch. It may require some debugging.
Comment 4 alexander :surkov 2012-01-18 08:10:05 PST
please cc us to bug 665820, I don't have an access too.
Comment 5 alexander :surkov 2012-01-18 08:22:54 PST
(In reply to alexander :surkov from comment #4)
> please cc us to bug 665820, I don't have an access too.

I missed that was supposed to be gnome bug, ignore my last comment.
Comment 6 alexander :surkov 2012-01-18 09:44:46 PST
(In reply to Ginn Chen from comment #2)
> but it looks like you're simply backout Bug
> 480317.

yep, that's what Trevor asked for in https://bugzilla.gnome.org/show_bug.cgi?id=665820 and it shouldn't be considered as proposed patch.
Comment 7 Trevor Saunders (:tbsaunde) 2012-01-18 11:43:35 PST
(In reply to alexander :surkov from comment #6)
> (In reply to Ginn Chen from comment #2)
> > but it looks like you're simply backout Bug
> > 480317.
> 
> yep, that's what Trevor asked for in
> https://bugzilla.gnome.org/show_bug.cgi?id=665820 and it shouldn't be
> considered as proposed patch.

yeah, I asked for it as an experiment not as a fix.
Comment 8 Trevor Saunders (:tbsaunde) 2012-01-25 23:41:40 PST
Created attachment 591712 [details] [diff] [review]
patch

noticed this while reviewing other stuff, it doesn't really make sense to treat "" as a valid atk plug id
Comment 9 alexander :surkov 2012-01-26 00:15:32 PST
Comment on attachment 591712 [details] [diff] [review]
patch

r=me for accessible module change, since don't see anything bad here but when this case happens?
Comment 10 Trevor Saunders (:tbsaunde) 2012-01-26 11:15:43 PST
(In reply to alexander :surkov from comment #9)
> Comment on attachment 591712 [details] [diff] [review]
> patch
> 
> r=me for accessible module change, since don't see anything bad here but
> when this case happens?

when the plugin  isn't accessible.  I'm not sure why  the plug id is "" but if I load a youtube video with a breakpoint in the constructor for AtkSocketAccessible I see that plugId its arg has mData of "".
Comment 11 Trevor Saunders (:tbsaunde) 2012-01-26 12:25:57 PST
landed https://hg.mozilla.org/integration/mozilla-inbound/rev/e4e85a8b32c7
Comment 12 Matt Brubeck (:mbrubeck) 2012-01-27 09:07:50 PST
https://hg.mozilla.org/mozilla-central/rev/e4e85a8b32c7
Comment 13 David Bolter [:davidb] 2012-01-27 10:53:24 PST
Comment on attachment 591712 [details] [diff] [review]
patch

Nice.

Note You need to log in before you can comment on or make changes to this bug.