The default bug view has changed. See this FAQ.

Digits-only file names get .css prefixed in front of postfixed

VERIFIED FIXED in Firefox 11

Status

()

Firefox
Developer Tools: Style Editor
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: AlexLakatos, Assigned: paul)

Tracking

11 Branch
Firefox 12
x86
Linux
Points:
---

Firefox Tracking Flags

(firefox11 verified)

Details

(Whiteboard: [qa!] [testday-20120203])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Digits-only file names get .css prefixed in front of postfixed

Steps to Reproduce
1.open the style editor
2.create a new style sheet
3.save it with a name with only digits, for example 1234.css

Actual results:
4.The stylesheet list shows css.1234

Expected results:
4.The stylesheet list shows 1234.css
(Assignee)

Comment 1

5 years ago
The problem is that we use `direction:rtl;` to simulate `XUL:crop=start` (part the Style Editor is in HTML).

To get rid of this workaround, I need to use a <xul:label>.
Priority: -- → P2
(Assignee)

Comment 2

5 years ago
Created attachment 590794 [details] [diff] [review]
patch v1
(Assignee)

Comment 3

5 years ago
Created attachment 590800 [details] [diff] [review]
patch v1.1
(Assignee)

Updated

5 years ago
Attachment #590794 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Attachment #590800 - Flags: review?(jwalker)
Attachment #590800 - Flags: feedback?(cedricv)
(Assignee)

Comment 4

5 years ago
(we will need a followup bug for the '*' not being display)
Comment on attachment 590800 [details] [diff] [review]
patch v1.1

Review of attachment 590800 [details] [diff] [review]:
-----------------------------------------------------------------

Does that mean we've lost the dirty * when a file is edited?
Attachment #590800 - Flags: review?(jwalker) → review+
(In reply to Paul Rouget [:paul] from comment #4)
> (we will need a followup bug for the '*' not being display)

Ahh - missed this comment.
(Assignee)

Updated

5 years ago
Blocks: 720468
Attachment #590800 - Flags: feedback?(cedricv) → feedback+
(Assignee)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
(Assignee)

Updated

5 years ago
Assignee: nobody → paul
(Assignee)

Updated

5 years ago
tracking-firefox11: --- → ?
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/2d2a7c5534e3
status-firefox12: --- → fixed
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
(Assignee)

Comment 8

5 years ago
I will a? this patch once in central.
Whiteboard: [fixed-in-fx-team] → [fixed-in-fx-team][addToFirefox11]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 710811
https://hg.mozilla.org/mozilla-central/rev/2d2a7c5534e3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team][addToFirefox11] → [addToFirefox11]
Target Milestone: --- → Firefox 12
Let's wait before a+ this.
The fix makes keyboard navigation in the list invisible.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 591531 [details] [diff] [review]
fix invisible outline for list keyboard navigation
Attachment #591531 - Flags: review?(paul)
(Assignee)

Comment 13

5 years ago
Comment on attachment 591531 [details] [diff] [review]
fix invisible outline for list keyboard navigation

Next time, please open a new bug.
Attachment #591531 - Flags: review?(paul) → review+
(Assignee)

Comment 14

5 years ago
Well, it's a little tricky. Can you mark this bug as fixed and open a new bug?
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Attachment #591531 - Attachment is obsolete: true
(Assignee)

Comment 15

5 years ago
Comment on attachment 590800 [details] [diff] [review]
patch v1.1

[Approval Request Comment]
Regression caused by (bug #): New Feature. Not a regression.
User impact if declined: Some stylesheet will be spelled wrong.
Testing completed (on m-c, etc.): on m-c, local testing.
Risk to taking this patch (and alternatives if risky): low. Styling changes and one XUL tag added.
Attachment #590800 - Flags: approval-mozilla-aurora?
tracking-firefox11: ? → ---
Comment on attachment 590800 [details] [diff] [review]
patch v1.1

[Triage Comment]
Low risk fix in support of a new feature. Approved for Aurora.
Attachment #590800 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 17

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/78d45f7defcd
status-firefox11: --- → fixed
status-firefox12: fixed → ---
Whiteboard: [addToFirefox11]
Whiteboard: [qa+]
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a2) Gecko/20120202 Firefox/12.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

Verified using the steps from comment 0 on Ubuntu 11.10, Firefox 11 Beta 1 and Firefox Aurora (12). The file name is saved normally as "1234.css"
Status: RESOLVED → VERIFIED
status-firefox11: fixed → verified
Whiteboard: [qa+] → [qa!]
Whiteboard: [qa!] → [qa!] [testday-20120203]
You need to log in before you can comment on or make changes to this bug.