Last Comment Bug 719025 - Unity Plugin flickers in Firefox 10 beta
: Unity Plugin flickers in Firefox 10 beta
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla10
Assigned To: Benoit Girard (:BenWa)
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 07:03 PST by Benoit Girard (:BenWa)
Modified: 2012-04-04 14:19 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
patch (2.05 KB, patch)
2012-01-19 12:22 PST, Benoit Girard (:BenWa)
smichaud: review+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Benoit Girard (:BenWa) 2012-01-18 07:03:53 PST
From Bug 692759 Comment 144:
We are seeing the same bug in unity. Try installing the unity plugin, and going to http://unity3d.com/gallery/demos/live-demos to see the problem. In Firefox 10, when running in 64 bit mode, this shows very bad flicker.
Comment 1 Benoit Girard (:BenWa) 2012-01-18 07:15:10 PST
This is fixed in Aurora (11) and Nightly (12).

Turning off 'plugins.use_layers' fixes the problem. I think it's safer to disable the feature in Firefox 10 and wait for 11 rather then to try to uplift the requires patches in Firefox 10.
Comment 2 Benoit Girard (:BenWa) 2012-01-19 12:22:36 PST
Created attachment 589950 [details] [diff] [review]
patch
Comment 3 Steven Michaud [:smichaud] (Retired) 2012-01-19 12:32:48 PST
Comment on attachment 589950 [details] [diff] [review]
patch

So this patch is intended only for the current beta branch?

On that assumption, this sounds reasonable to me.
Comment 4 Benoit Girard (:BenWa) 2012-01-19 12:42:29 PST
Comment on attachment 589950 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 589950
User impact if declined: Flicker and regression with some plug-ins, including Unity.
Testing completed (on m-c, etc.): Checked that the feature is correctly 
Risk to taking this patch (and alternatives if risky): Low, flipping a switch to turn off a feature. Alternative is uplifting non trivial c++ code changes.

That's correct, turning this off once more :(. I wish these issues would turn up sooner.
Comment 5 Alex Keybl [:akeybl] 2012-01-19 16:30:13 PST
(In reply to Benoit Girard (:BenWa) from comment #4)
> Comment on attachment 589950 [details] [diff] [review]
> patch
> 
> [Approval Request Comment]
> Regression caused by (bug #): 589950

Hi Benoit - this doesn't appear to be the correct regressing bug. I'm interested in finding out how long the feature being disabled has been in the product, what platforms are affected, etc.
Comment 6 Benoit Girard (:BenWa) 2012-01-19 17:31:02 PST
(In reply to Alex Keybl [:akeybl] from comment #5)
> (In reply to Benoit Girard (:BenWa) from comment #4)
> > Comment on attachment 589950 [details] [diff] [review]
> > patch
> > 
> > [Approval Request Comment]
> > Regression caused by (bug #): 589950
> 
> Hi Benoit - this doesn't appear to be the correct regressing bug. I'm
> interested in finding out how long the feature being disabled has been in
> the product, what platforms are affected, etc.

I meant to link to this bug. This feature has never been enable. It was going to be enabled for the first time this release.
Comment 7 Alex Keybl [:akeybl] 2012-01-22 17:32:44 PST
Comment on attachment 589950 [details] [diff] [review]
patch

[Triage Comment]
Since this is the first release that we were going to enable this feature for, I have no issue with disabling for one more release. Approved for beta.
Comment 8 Alex Keybl [:akeybl] 2012-01-22 17:34:46 PST
(please land by tomorrow 1/23 evening to make beta 6)
Comment 9 Benoit Girard (:BenWa) 2012-01-22 18:43:52 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/138e167dcd3d
Comment 10 Benoit Girard (:BenWa) 2012-04-04 14:19:01 PDT
This landed and should be fixed, please let us know if you see this again.

Note You need to log in before you can comment on or make changes to this bug.