Last Comment Bug 719154 - Remove support for nested event loop filters
: Remove support for nested event loop filters
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla14
Assigned To: Benjamin Smedberg [:bsmedberg]
:
:
Mentors:
: 582120 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 11:22 PST by Benjamin Smedberg [:bsmedberg]
Modified: 2013-09-10 10:22 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove nested event loop filtering, rev. 1 (9.75 KB, patch)
2012-01-18 11:22 PST, Benjamin Smedberg [:bsmedberg]
justin.lebar+bug: review+
Details | Diff | Splinter Review

Description Benjamin Smedberg [:bsmedberg] 2012-01-18 11:22:10 PST
Created attachment 589582 [details] [diff] [review]
Remove nested event loop filtering, rev. 1

With the removal of XPCOM proxies, we can now safely also remove the rather complicated thread support for nested event loop filters. These never worked well because native events weren't usefully filtered, and even if we want to end up with something like DOM event sources as in the HTML spec, the current code will not be useful at all.
Comment 1 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-01-19 14:48:42 PST
Could you ask somebody else to review this?
Comment 2 Benjamin Smedberg [:bsmedberg] 2012-01-21 12:13:04 PST
Comment on attachment 589582 [details] [diff] [review]
Remove nested event loop filtering, rev. 1

Apparently I need to find somebody to own/be a peer of this code.
Comment 3 Justin Lebar (not reading bugmail) 2012-01-23 09:12:21 PST
Comment on attachment 589582 [details] [diff] [review]
Remove nested event loop filtering, rev. 1

This patch is clearly fine in itself, but I admit that I don't know what an xpcom proxy is or why their removal means we can remove this code.  I'm reading bug 675221, but I may be at it for a while.  :)
Comment 4 Justin Lebar (not reading bugmail) 2012-01-23 09:26:22 PST
Okay, I see.  Or at least, think I've seen enough!  :)
Comment 5 Ed Morley [:emorley] 2012-03-24 13:57:41 PDT
https://hg.mozilla.org/mozilla-central/rev/1b05e9751f34
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2013-09-10 10:22:30 PDT
*** Bug 582120 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.