Closed Bug 719226 Opened 11 years ago Closed 8 years ago

CalDAV calendars are not visible in the 'select calendar' dialog

Categories

(Calendar :: Provider: CalDAV, defect)

Lightning 1.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 865726

People

(Reporter: marcel, Unassigned)

Details

(Whiteboard: [calconnect31])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

Steps to reproduce:

CalDAV calendars are usually not displayed in the dialog that allows to select to which calendar an event (based on an invitation by email) should be added.

Bug 463392 describes the exact same behavior but it's marked as fixed. 

In http://goo.gl/VtVUa (Google usenet archive) I also described the behavior a long time ago.

The problem is that I don't have a reproducible test case/scenario. Most often the remote calendar is not listed in the dialog but from time to time it is... very frustrating.

I guess there's only one way to get more info:
- I need to somehow run TB/Lightning in "debug mode" (how?)  as the error console contains no hints
- set a break point in the code that decides whether to list a particular calendar or not (where is that code?)
Hello,

one (in my case reliable) way to reproduce this is to use the owncloud CalDav server. The calendars work perfectly (create, display, modify for entries works), the correct email.address is selectable in the calendar's properties but the CalDav calendars are not considered for accepting invitations. On the console there is just the error, that there are no suitable calendars (itipitem.targetCalendar is null in calltipUtils.jsm line 522) unless non CalDav calendars are available.
(Thunderbird 10.0, Lightning 1.2.1, owncloud 3.0)
i can confirm this with TB 15.0.1 and Lightning 1.7.  When I add the calendar I am allowed to associate my email address - something I could not do with provider for google, but my calendar does not show up to be selected when I get an invite.
Whiteboard: [calconnect31]
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865726
You need to log in before you can comment on or make changes to this bug.