Last Comment Bug 719253 - Fennec cannot init EGL libs due to wrong library name
: Fennec cannot init EGL libs due to wrong library name
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla12
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks: 716825
  Show dependency treegraph
 
Reported: 2012-01-18 15:23 PST by Oleg Romashin (:romaxa)
Modified: 2012-01-26 23:59 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Switch back to old library names (635 bytes, patch)
2012-01-18 16:12 PST, Oleg Romashin (:romaxa)
mh+mozilla: review-
Details | Diff | Splinter Review
Lookup for EGL library (1.58 KB, patch)
2012-01-19 23:18 PST, Oleg Romashin (:romaxa)
mh+mozilla: review+
blassey.bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2012-01-18 15:23:56 PST
In bug 716825

not only full path to libraries was removed, but also library names changed too
for example:
-#define EGL_LIB "/usr/lib/libEGL.so"
-#define GLES2_LIB "/usr/lib/libGLESv2.so"
+#define EGL_LIB "libEGL.so.1"
+#define GLES2_LIB "libGLESv2.so.2"

Not sure home many non-android egl based systems we have, but most of them similar to android have only libEGL.so, and without api suffix.
Comment 1 Oleg Romashin (:romaxa) 2012-01-18 16:12:02 PST
Created attachment 589692 [details] [diff] [review]
Switch back to old library names
Comment 2 Mike Hommey [:glandium] 2012-01-18 23:00:50 PST
Comment on attachment 589692 [details] [diff] [review]
Switch back to old library names

Review of attachment 589692 [details] [diff] [review]:
-----------------------------------------------------------------

See bug 716825 comment 7
Comment 3 Oleg Romashin (:romaxa) 2012-01-19 23:18:45 PST
Created attachment 590125 [details] [diff] [review]
Lookup for EGL library
Comment 4 Mike Hommey [:glandium] 2012-01-19 23:37:20 PST
Comment on attachment 590125 [details] [diff] [review]
Lookup for EGL library

Review of attachment 590125 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/gl/GLContextProviderEGL.cpp
@@ +385,5 @@
>  #endif
>  
>          if (!mEGLLibrary) {
>              mEGLLibrary = PR_LoadLibrary(EGL_LIB);
> +#if defined(XP_UNIX)

It's probably too broad, but it doesn't hurt.
Comment 5 Ed Morley [:emorley] 2012-01-21 05:55:58 PST
https://hg.mozilla.org/mozilla-central/rev/cf45def338fa
Comment 6 Mike Hommey [:glandium] 2012-01-25 09:44:19 PST
Comment on attachment 590125 [details] [diff] [review]
Lookup for EGL library

[Approval Request Comment]
Regression caused by bug 716825, which is a dependency of bug 683127.
Comment 7 Mike Hommey [:glandium] 2012-01-26 23:59:58 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/47cb704586dc

Note You need to log in before you can comment on or make changes to this bug.