Closed Bug 719263 Opened 10 years ago Closed 10 years ago

sign_android script should verify passwords before signing

Categories

(Release Engineering :: General, defect, P3)

x86
Windows Server 2003
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 705214

People

(Reporter: coop, Unassigned)

Details

(Whiteboard: [release-process-improvement][automation][signing])

I ran into an issue with signing for 10.0b5:

https://wiki.mozilla.org/Releases/Firefox_10.0b5/BuildNotes#Android_Signature_Verification

In short, I had the wrong store password, but the script didn't halt. It continued to the point of uploading the improperly signed apks. This triggered the verification step which subsequently failed.

We should be able to leverage some smarts from the CombinedSigning process here namely:

* accepting both passwords up-front so you only have to input them once
* verifying the passwords with a test signing before using them on the actual apks
* allow for password re-entry if an error is detected, or at the very least, halt the script so we don't upload unsigned apks as signed
The new mozharness script should fix this.
It's due along with the rest of my work by 1/31, so in the near future.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 705214
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.