Last Comment Bug 719271 - Site-specific zoom level shouldn't apply to video and plugin documents
: Site-specific zoom level shouldn't apply to video and plugin documents
Status: RESOLVED FIXED
: polish
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Firefox 12
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
: 466909 (view as bug list)
Depends on: 416661 806046 842001
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 16:12 PST by Matt Brubeck (:mbrubeck)
Modified: 2013-02-15 22:55 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (8.38 KB, patch)
2012-01-19 20:07 PST, Matt Brubeck (:mbrubeck)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Matt Brubeck (:mbrubeck) 2012-01-18 16:12:08 PST
Bug 416661 excluded images from site-specific zooming, because "it is quite annoying to see normal pages zoomed when using pagezoom to zoom images" (bug 416661 comment 0).

Bug 575830 comment 33 pointed out that this the same logic applies to other media document types, like video documents.  We should update the code in browser-fullZoom.js to check mozSyntheticDocument instead of just "instanceof ImageDocument".
Comment 1 Mozilla RelEng Bot 2012-01-19 17:01:21 PST
Try run for 8b7a0a182a1d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=8b7a0a182a1d
Results (out of 8 total builds):
    exception: 8
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mbrubeck@mozilla.com-8b7a0a182a1d
Comment 2 Matt Brubeck (:mbrubeck) 2012-01-19 20:07:09 PST
Created attachment 590090 [details] [diff] [review]
patch
Comment 3 Mozilla RelEng Bot 2012-01-19 21:45:37 PST
Try run for 0b586a5b7229 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0b586a5b7229
Results (out of 155 total builds):
    success: 136
    warnings: 18
    failure: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mbrubeck@mozilla.com-0b586a5b7229
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-20 09:07:43 PST
Comment on attachment 590090 [details] [diff] [review]
patch

Did the test fail before the patch? Jared suggested it doesn't in bug 575830 comment 35. Maybe some other form of synthetic document would make a better test?
Comment 5 Matt Brubeck (:mbrubeck) 2012-01-20 10:20:50 PST
(In reply to Gavin Sharp (use gavin@gavinsharp.com for email) from comment #4)
> Did the test fail before the patch? Jared suggested it doesn't in bug 575830
> comment 35. Maybe some other form of synthetic document would make a better
> test?

Yes, the test fails without the patch.  Before the patch, video documents used site-specific zoom.  So they weren't affected by bug 575830 (zoom resets to 1 on tab switching), but zooming a video would cause other pages in the site to zoom and vice-versa (which is the problem that bug 416661 fixed for images).
Comment 7 Ed Morley [:emorley] 2012-01-21 05:59:06 PST
https://hg.mozilla.org/mozilla-central/rev/ade1cb934f01
Comment 8 Paul Adenot (:padenot) 2012-04-30 13:06:19 PDT
*** Bug 466909 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.