Last Comment Bug 719283 - WebSMS: Update RIL backend to match latest interface changes
: WebSMS: Update RIL backend to match latest interface changes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: Philipp von Weitershausen [:philikon]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: b2g-sms
  Show dependency treegraph
 
Reported: 2012-01-18 16:57 PST by Philipp von Weitershausen [:philikon]
Modified: 2012-01-19 17:42 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Part 1: Fix SmsService (835 bytes, patch)
2012-01-18 17:11 PST, Philipp von Weitershausen [:philikon]
mounir: review+
Details | Diff | Splinter Review
Part 2: Add stub SmsDatabaseService (571 bytes, patch)
2012-01-18 17:14 PST, Philipp von Weitershausen [:philikon]
mounir: review+
Details | Diff | Splinter Review

Description Philipp von Weitershausen [:philikon] 2012-01-18 16:57:17 PST
Bug 674725 landed (yay!) but it broke the RIL SMS implementation a bit since it changed some interfaces on nsISmsService. No biggie, /me fixes.
Comment 1 Philipp von Weitershausen [:philikon] 2012-01-18 17:11:35 PST
Created attachment 589709 [details] [diff] [review]
Part 1: Fix SmsService
Comment 2 Philipp von Weitershausen [:philikon] 2012-01-18 17:14:47 PST
Created attachment 589711 [details] [diff] [review]
Part 2: Add stub SmsDatabaseService

This isn't an actual SmsDatabaseService implementation of course, but it makes the damn thing compile. Bug 712809 is going to be the real deal.
Comment 3 Philipp von Weitershausen [:philikon] 2012-01-19 12:59:29 PST
I was asked to push these to unblock other people from the bustage:

https://hg.mozilla.org/integration/mozilla-inbound/rev/8ddf16173206
https://hg.mozilla.org/integration/mozilla-inbound/rev/cebc16a770fb
Comment 4 Mounir Lamouri (:mounir) 2012-01-19 15:30:12 PST
Sorry for the delay, I was traveling today.

Note You need to log in before you can comment on or make changes to this bug.