Last Comment Bug 719329 - TorButton causes memory leaks/growth
: TorButton causes memory leaks/growth
Status: RESOLVED WORKSFORME
[MemShrink:P3]
:
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://www.torproject.org/torbutton/
Depends on:
Blocks: LeakyAddons
  Show dependency treegraph
 
Reported: 2012-01-18 21:21 PST by Randell Jesup [:jesup]
Modified: 2012-02-16 08:44 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Randell Jesup [:jesup] 2012-01-18 21:21:17 PST
From bug 490122:

randall@dasaku.net (New to Bugzilla) 2012-01-18 18:42:25 PST

I did an exhaustive run through of my add-ons after launching in Safe-Mode determined that it was an add-on based problem for me.

After disabling everything, it came to it that TorButton was the add-on that was causing the problem, so I'd say if you're running TorButton and launching firefox in safe-mode fixes the issue, start by disabling TorButton just to give it a shot.
Comment 1 Nicholas Nethercote [:njn] 2012-01-18 21:29:47 PST
https://www.torproject.org/torbutton/ is the URL.  It says:

"Now that the Tor Browser Bundle includes a patched version of Firefox, and because we don't have enough developer resources to keep up with the accelerated Firefox release schedule, the toggle model of Torbutton is no longer recommended. Users should be using Tor Browser Bundle, not installing Torbutton themselves."

The Tor Browser Bundle is a custom version of Firefox, presumably an oldish one, with the extension installed.  It's at https://www.torproject.org/projects/torbrowser.html.en.  Weird.
Comment 2 Nicholas Nethercote [:njn] 2012-01-18 21:32:30 PST
Also, TorButton isn't available on AMO, so we can't do anything about it via that route.
Comment 3 Justin Lebar (not reading bugmail) 2012-01-24 14:00:10 PST
What's sad about this is that they're encouraging people to use an *insecure* version of Firefox.  For Tor, the most paranoid of Web services!
Comment 4 Justin Lebar (not reading bugmail) 2012-01-24 17:26:39 PST
I e-mailed the tor-assistants list.

It looks like Tor Browser is currently Aurora 9.0.1.  :(
Comment 5 Sebastian Hahn 2012-01-24 18:53:17 PST
It looks like Mozilla's naming/name trademark policy is confusing even for the Mozilla folk. Firefox 9.0.1 when build without the Firefox branding calls itself Aurora, and we cannot call it Firefox due to the modifications we need to make. Please try to confirm asap whether there actually is an older version shipped, before making such claims.
Comment 6 Justin Lebar (not reading bugmail) 2012-01-24 18:56:49 PST
> Please try to confirm asap whether there actually is an older version shipped, before making such 
> claims.

I'm sorry for the confusion.

I think you can rename the binary by setting MOZ_APP_DISPLAYNAME in your .mozconfig.  You can't call it "Firefox", but you could call it "Tor Browser".
Comment 7 Justin Lebar (not reading bugmail) 2012-01-25 07:23:58 PST
I haven't been able to reproduce this leak, either with TorBrowser or in Nightly with Tor Button (installed but with Tor disabled).  I browsed around to maybe 10 sites and didn't see abnormal memory growth or zombie compartments.

John, do you have a rough set of steps to reproduce?
Comment 8 Justin Lebar (not reading bugmail) 2012-02-16 08:44:37 PST
Closing as WFM per comment 7.  Please re-open if you have STR.

Note You need to log in before you can comment on or make changes to this bug.