Last Comment Bug 719453 - Expose Orion's getLineStart/getLineEnd in SourceEditor
: Expose Orion's getLineStart/getLineEnd in SourceEditor
Status: RESOLVED FIXED
[sourceeditor][good first bug][mentor...
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: Firefox 14
Assigned To: Pranav Ravichandran [:pranavrc]
:
:
Mentors:
Depends on:
Blocks: 725430
  Show dependency treegraph
 
Reported: 2012-01-19 08:38 PST by Cedric Vivier [:cedricv]
Modified: 2012-03-29 12:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Cedric Vivier [:cedricv] 2012-01-19 08:38:57 PST
This will be useful to perform efficient line-based getText.
Comment 1 Mihai Sucan [:msucan] 2012-02-09 11:13:41 PST
Cedric: are you working on this bug?
Comment 2 Pranav Ravichandran [:pranavrc] 2012-02-22 05:43:44 PST
Since I'm working on the related bug(725430), I'd be willing to work on this in case Cedric is unable to.
Comment 3 Cedric Vivier [:cedricv] 2012-02-22 05:53:25 PST
(In reply to Pranav Ravichandran [:pranavrc] from comment #2)
> Since I'm working on the related bug(725430), I'd be willing to work on this
> in case Cedric is unable to.

Awesome. Feel free to take it over then :)
Comment 4 Pranav Ravichandran [:pranavrc] 2012-02-22 05:56:42 PST
Thanks! Could you reassign the bug?
Comment 5 Mihai Sucan [:msucan] 2012-02-22 05:57:20 PST
Thank you Pranav!
Comment 6 Pranav Ravichandran [:pranavrc] 2012-02-24 07:32:58 PST
I've added a possible patch for this along with the patch in bug https://bugzilla.mozilla.org/show_bug.cgi?id=725430
Comment 7 Pranav Ravichandran [:pranavrc] 2012-03-28 08:36:50 PDT
Can this be closed now?
Comment 8 Mihai Sucan [:msucan] 2012-03-29 12:27:15 PDT
Yes! This is fixed by bug 725430. Thank you Pranav!

Note You need to log in before you can comment on or make changes to this bug.