Last Comment Bug 719457 - When the URLs are very long (style editor), the user needs to resize to see the editor.
: When the URLs are very long (style editor), the user needs to resize to see t...
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Style Editor (show other bugs)
: unspecified
: x86 Mac OS X
-- normal (vote)
: Firefox 12
Assigned To: Paul Rouget [:paul]
:
: Gabriel Luong [:gl][1 biz day review guarantee] (ΦωΦ)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-19 08:50 PST by David Bolter [:davidb]
Modified: 2013-11-01 01:58 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
verified
verified


Attachments
patch v1 (1.01 KB, patch)
2012-01-23 09:29 PST, Paul Rouget [:paul]
jwalker: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image David Bolter [:davidb] 2012-01-19 08:50:56 PST
Ping me if you need STR.
Comment 1 User image Paul Rouget [:paul] 2012-01-23 09:29:26 PST
Created attachment 590743 [details] [diff] [review]
patch v1
Comment 2 User image Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-23 12:02:26 PST
Comment on attachment 590743 [details] [diff] [review]
patch v1

Review of attachment 590743 [details] [diff] [review]:
-----------------------------------------------------------------

400px feels arbitrary. Is there no better way?
Comment 3 User image Paul Rouget [:paul] 2012-01-23 12:12:48 PST
(In reply to Joe Walker from comment #2)
> Comment on attachment 590743 [details] [diff] [review]
> patch v1
> 
> Review of attachment 590743 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> 400px feels arbitrary. Is there no better way?

It is half of the original size: http://mxr.mozilla.org/mozilla-central/source/browser/devtools/styleeditor/styleeditor.xul#53
Comment 4 User image Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-23 12:24:13 PST
(In reply to Paul Rouget [:paul] from comment #3)
> (In reply to Joe Walker from comment #2)
> > Comment on attachment 590743 [details] [diff] [review]
> > patch v1
> > 
> > Review of attachment 590743 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > 400px feels arbitrary. Is there no better way?
> 
> It is half of the original size:
> http://mxr.mozilla.org/mozilla-central/source/browser/devtools/styleeditor/
> styleeditor.xul#53

I was wondering if there wasn't a better solution than using an absolute value, but I realize that it can be hard.
Comment 5 User image Paul Rouget [:paul] 2012-01-25 05:13:51 PST
https://hg.mozilla.org/integration/fx-team/rev/c34ef990df33
Comment 6 User image Paul Rouget [:paul] 2012-01-25 05:36:42 PST
I will a? this patch once in central.
Comment 7 User image Tim Taubert [:ttaubert] 2012-01-25 09:07:48 PST
https://hg.mozilla.org/mozilla-central/rev/c34ef990df33
Comment 8 User image Rob Campbell [:rc] (:robcee) 2012-01-25 10:24:34 PST
Comment on attachment 590743 [details] [diff] [review]
patch v1

[Approval Request Comment]
Regression caused by (bug #): New Feature. Not a regression.
User impact if declined: User will have to resize to see the editor.
Testing completed (on m-c, etc.): on m-c, local testing.
Risk to taking this patch (and alternatives if risky): Negligble. Styling only.
Comment 9 User image Alex Keybl [:akeybl] 2012-01-25 18:30:36 PST
Comment on attachment 590743 [details] [diff] [review]
patch v1

[Triage Comment]
Regression in new feature, approved for Aurora.
Comment 10 User image Rob Campbell [:rc] (:robcee) 2012-01-26 12:47:45 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/cc4219ead50b
Comment 11 User image Simona B [:simonab ] 2012-02-22 08:39:19 PST
Verified using Firefox 11 beta 3 on Windows 7, Ubuntu 11.10 and Mac OS X 10.6.

Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0

The user does not need to resize the editor in order to see it, the URL's can not be dragged wider than 400px.
Comment 12 User image Simona B [:simonab ] 2012-03-23 06:22:42 PDT
Verified as fixed on Firefox 12 beta 2 - the user does not need to resize the editor in order to see it, the URL's can not be dragged wider than 400px.

Verified on Windows 7, Ubuntu 11.10 and Mac OS X 10.6.
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (X11; Linux i686; rv:12.0) Gecko/20100101 Firefox/12.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0) Gecko/20100101 Firefox/12.0

Setting resolution to VERIFIED FIXED.
Comment 13 User image Matty Balaam 2013-11-01 01:57:58 PDT
On Firefox 26 long filenames seem to be displayed in full again. e.g. I have one that is 1214px wide
Comment 14 User image Matty Balaam 2013-11-01 01:58:39 PDT
Sorry, this is on the PC version. Should I open a different bug?

Note You need to log in before you can comment on or make changes to this bug.