World Online Norway http:/ (with one slash) used in redirect URL

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
Norwegian
P4
major
VERIFIED WORKSFORME
17 years ago
3 years ago

People

(Reporter: fpcosta, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [SYNTAX-HTML], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8.1) Gecko/20010309
BuildID:    2001030920

If a page as the following HTML code:

<html>
<head>
<meta http-equiv="refresh" 
          content="1; url=http:/servlet/body" >
</head>
...
</html>

You can see the meta refresh and the way the URL is coded:

url=http:/servlet/body

This means that the refresh will load the page http://www.whatever.net/servlet/body

But in Mozilla when the refresh happens tries to find the website
http:/servlet/body which doesn't exist and of course loads the page from
netscape search saying invalid name or similar.

All of this is inside a frame, so all the other frames are correct, only the one
with the refresh gets redirected to Netscape.

If i use Netscape 4.76 or Internet Explorer everything works fine.

Regards and keep up the excellent work.


Reproducible: Always
Steps to Reproduce:
Make a page with the code:

<html>
<head>
<meta http-equiv="refresh"
content="1; url=http:/servlet/body" >
</head>
...
</html>

And load it in Mozilla

Actual Results:  You get redirected to Netscape search site.

Expected Results:  It should load the page from the url
URLs of the form http:/foo/bar (relative urls with protocol part) are disallowed
per RFC 2396.

See bug 32966 for details.

reassigning to evangelism.
Assignee: clayton → evangelism
Status: UNCONFIRMED → NEW
Component: HTML Element → Evangelism
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: bsharma → zach
Summary: META refresh URL redirects page to Netscape search pages → http:/ (with one slash) used in redirect URL

Comment 2

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Updated

17 years ago
Priority: -- → P4
Whiteboard: [SYNTAX-HTML]

Comment 3

17 years ago
Assigning to Euro Evangelist
Assignee: bclary → nitot
Summary: http:/ (with one slash) used in redirect URL → World Online Norway http:/ (with one slash) used in redirect URL

Updated

17 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified
.
QA Contact: zach → momoi

Comment 5

16 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Component: European → West Europe
QA Contact: momoi → caillon

Comment 6

16 years ago
looks like the issue was fixed, but there is now layout issues
Layout looks fine now. Closing WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
Verify fixed.  url redirects properly now.
Status: RESOLVED → VERIFIED

Comment 9

15 years ago
tech evang june 2003 reorg
Component: Europe: West → Norwegian
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.