Closed Bug 719736 Opened 8 years ago Closed 8 years ago

TEST-UNEXPECTED-FAIL | test_current_from_v10.js | 0 == 6

Categories

(Toolkit :: Places, defect)

All
Windows Server 2003
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: standard8, Assigned: mak)

References

Details

(Keywords: intermittent-failure)

Since bug 699751 landed, we've been seeing this failure on our Windows test boxes on Thunderbird builds:

TEST-UNEXPECTED-FAIL | e:/buildbot/comm-central-win32-opt-unittest-xpcshell/build/xpcshell/tests/toolkit/components/places/tests/migration/test_current_from_v10.js | 0 == 6 - See following stack:
JS frame :: e:\buildbot\comm-central-win32-opt-unittest-xpcshell\build\xpcshell\head.js :: do_throw :: line 462
JS frame :: e:\buildbot\comm-central-win32-opt-unittest-xpcshell\build\xpcshell\head.js :: _do_check_eq :: line 556
JS frame :: e:\buildbot\comm-central-win32-opt-unittest-xpcshell\build\xpcshell\head.js :: do_check_eq :: line 577
JS frame :: e:/buildbot/comm-central-win32-opt-unittest-xpcshell/build/xpcshell/tests/toolkit/components/places/tests/migration/test_current_from_v10.js :: test_moz_hosts :: line 304
JS frame :: e:\buildbot\comm-central-win32-opt-unittest-xpcshell\build\xpcshell\head.js :: _run_next_test :: line 882
JS frame :: e:\buildbot\comm-central-win32-opt-unittest-xpcshell\build\xpcshell\head.js :: <TOP_LEVEL> :: line 429

These are opt builds running on VMs, so could there be a timing issue processing the sql statement?
yeah, it's possible we are not waiting for something. I'll look into it.
Assignee: nobody → mak77
Blocks: 438871
The problem is that moz_hosts is populated asynchronously but we check it synchronously, will fix this in bug 720258 since I have to add some test there.
Depends on: 720258
fixed by bug 720258
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.