Last Comment Bug 719749 - IonMonkey: Assertion failure: interval->start() < pos && pos < interval->end(), at LinearScan.cpp:1238
: IonMonkey: Assertion failure: interval->start() < pos && pos < interval->end(...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-01-20 03:52 PST by Jan de Mooij [:jandem]
Modified: 2012-01-20 08:42 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (4.50 KB, patch)
2012-01-20 03:52 PST, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-01-20 03:52:36 PST
Created attachment 590165 [details] [diff] [review]
Patch

setPropTypeGuard.js and Frame-onStep-07.js fail with this assert.

The problem is that LCallSetPropertyT does not use at-start for its operands. We can fix the instruction to use *AtStart, but I think we should do what you suggested a while ago: make call instruction operands default to at-start.
Comment 1 Jan de Mooij [:jandem] 2012-01-20 08:42:04 PST
https://hg.mozilla.org/projects/ionmonkey/rev/fe0c029a7bc4

Note You need to log in before you can comment on or make changes to this bug.