Note: There are a few cases of duplicates in user autocompletion which are being worked on.

[markup panel] The HTML Tree should have its own keybindings

RESOLVED FIXED in Firefox 16

Status

()

Firefox
Developer Tools: Inspector
P3
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: paul, Unassigned)

Tracking

Trunk
Firefox 16
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

v1
18.38 KB, patch
dcamp
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
The keybindings in the inspector map the layout of the Breadcrumbs (left for parent node for example). The HTML Tree has a different layout, and some keybindings don't make sense.

Up and Down should select the next line in the tree. Even if the line is a closing tag.
Left and Right should Close and Open the current Node.
Priority: -- → P3
(Reporter)

Updated

5 years ago
Duplicate of this bug: 754661
(In reply to Paul Rouget [:paul] from bug 754661 comment #4)
> iirc, we had to disable the shortcut because they were messing with the
> other highlighter shortcuts, and they were confusing (up and down to visit
> the parent and descendants, right and left to visit the siblings).

Not confusing for users of Firebug. I think it's fairly standard tree-view navigation for left/right to close and open tree-items and up down to navigate. Maybe that's made confusing because of the breadcrumb navigation keys.
(Reporter)

Comment 3

5 years ago
(In reply to Rob Campbell [:rc] (:robcee) from comment #2)
> (In reply to Paul Rouget [:paul] from bug 754661 comment #4)
> > iirc, we had to disable the shortcut because they were messing with the
> > other highlighter shortcuts, and they were confusing (up and down to visit
> > the parent and descendants, right and left to visit the siblings).
> 
> Not confusing for users of Firebug. I think it's fairly standard tree-view
> navigation for left/right to close and open tree-items and up down to
> navigate. Maybe that's made confusing because of the breadcrumb navigation
> keys.

Yes. And we should implement this behavior. But that is not what we got in the tree view.

Before:
* up/down, visit siblings;
* right/left, visit parents/descendants.

Firebug (and what we should implement):
* up/down, visit the previous (or next) element in the tree (like a cursor);
* left/right, fold/unfold a node.

We should use these shortcuts as soon as the treeview is open (even if not focused).

Comment 4

5 years ago
Created attachment 629436 [details] [diff] [review]
WIP

This patch implements the keybindings if the tree is focused.  But I think agree with paul, that they should be true if the html panel is open at all.

Also doesn't have tests, but I don't want to lose this patch.
(Reporter)

Updated

5 years ago
Summary: The HTML Tree should have its own keybindings → [markup panel] The HTML Tree should have its own keybindings
(Reporter)

Comment 5

5 years ago
Created attachment 639101 [details] [diff] [review]
v1
(Reporter)

Updated

5 years ago
Attachment #629436 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Attachment #629436 - Flags: review?(dcamp)

Updated

5 years ago
Attachment #639101 - Flags: review+

Updated

5 years ago
Attachment #629436 - Flags: review?(dcamp)
(Reporter)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
(Reporter)

Comment 6

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/28473532325e
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/28473532325e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 16
You need to log in before you can comment on or make changes to this bug.