accessibility API mapping for section element

RESOLVED DUPLICATE of bug 614310

Status

()

Firefox
Disability Access
RESOLVED DUPLICATE of bug 614310
6 years ago
6 years ago

People

(Reporter: steve faulkner, Unassigned)

Tracking

11 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:11.0a2) Gecko/20120116 Firefox/11.0a2
Build ID: 20120116042010

Steps to reproduce:

looked at the IA2 mapping for the HTML5 section element.


Actual results:

it is exposed as an IA2 paragraph role


Expected results:

the Ia2 paragraph role definition = 
IA2_ROLE_PARAGRAPH 	A paragraph of text.
the HTML5 section element is defined:
"The section element represents a generic section of a document or application. A section, in this context, is a thematic grouping of content, typically with a heading.

Examples of sections would be chapters, the various tabbed pages in a tabbed dialog box, or the numbered sections of a thesis. A Web site's home page could be split into sections for an introduction, news items, and contact information."

Which does not appear to fit with the IA2 paragraph definition, but seems closer to the IA2 section role.

"IA2_ROLE_SECTION 	A container of document content. An example of the use of this role is to represent an HTML DIV tag. A section may be used as a region. A region is a group of elements that together form a perceivable unit. A region does not necessarily follow the logical structure of the content, but follows the perceivable structure of the page."

iA2 roles: http://accessibility.linuxfoundation.org/a11yspecs/ia2/docs/html/_accessible_role_8idl.html
HTML5 section: http://dev.w3.org/html5/spec/the-section-element.html#the-section-element
(Reporter)

Updated

6 years ago
Component: Untriaged → Disability Access

Updated

6 years ago
QA Contact: untriaged → disability.access

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614310
You need to log in before you can comment on or make changes to this bug.