Last Comment Bug 719933 - In the Inspector, the arrowkeys shortcuts should be used only when the higlighter or the toolbar are focused
: In the Inspector, the arrowkeys shortcuts should be used only when the higlig...
Status: RESOLVED FIXED
[qa+]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 12
Assigned To: Paul Rouget [:paul]
:
Mentors:
: 698752 719834 719866 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-20 11:55 PST by Paul Rouget [:paul]
Modified: 2012-03-29 14:59 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
patch v1 (12.95 KB, patch)
2012-01-20 13:03 PST, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
patch v3 (15.17 KB, patch)
2012-01-20 16:29 PST, Paul Rouget [:paul]
rcampbell: review+
Details | Diff | Splinter Review
patch v3.1 (15.17 KB, patch)
2012-01-24 10:58 PST, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
patch 3.1 - rebased (14.99 KB, patch)
2012-01-25 04:52 PST, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review

Description Paul Rouget [:paul] 2012-01-20 11:55:03 PST

    
Comment 1 Paul Rouget [:paul] 2012-01-20 12:47:49 PST
*** Bug 719866 has been marked as a duplicate of this bug. ***
Comment 2 Paul Rouget [:paul] 2012-01-20 12:48:26 PST
*** Bug 719834 has been marked as a duplicate of this bug. ***
Comment 3 Paul Rouget [:paul] 2012-01-20 13:03:37 PST
Created attachment 590309 [details] [diff] [review]
patch v1
Comment 4 Paul Rouget [:paul] 2012-01-20 13:12:03 PST
We can't have the same event logic for the arrowkeys and the other keys. Because we don't want the arrow keys to be used when we are (focused) in the sidebar or in the HTML tree, because the keys mean something else there.

We can't move all the event in the same place because some keys are used everywhere (ESC for example).

So in this patch, I moved all the arrowkeys event logic in the breadcrumbs code because the browsing-logic should follow the current breadcrumbs layout (see bug 719834).

Only 3 elements of the UI should use the arrowkey events:
- Toolbar (not just the breadcrumbs)
- The highlighter veil
- The content window (because the highlighter veil can be key-event-unsensitive with pointer-events:none)
Comment 5 Paul Rouget [:paul] 2012-01-20 13:12:55 PST
Well, no. I think I get that wrong.
Comment 6 Paul Rouget [:paul] 2012-01-20 16:29:51 PST
Created attachment 590385 [details] [diff] [review]
patch v3
Comment 7 Paul Rouget [:paul] 2012-01-23 05:44:48 PST
*** Bug 698752 has been marked as a duplicate of this bug. ***
Comment 8 Rob Campbell [:rc] (:robcee) 2012-01-23 11:43:58 PST
Comment on attachment 590385 [details] [diff] [review]
patch v3

+  /**
+   * Remove the event listeners for the arrowkeys.
+   */
+   cleanNavigationKeys:

I might change that name to "clearNavigationKeys" or even "remove".

Presumably the existing unittests work for this?
Comment 9 Paul Rouget [:paul] 2012-01-24 10:58:00 PST
Created attachment 591178 [details] [diff] [review]
patch v3.1
Comment 10 Paul Rouget [:paul] 2012-01-25 04:52:31 PST
Created attachment 591422 [details] [diff] [review]
patch 3.1 - rebased
Comment 12 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-01-25 09:05:24 PST
https://hg.mozilla.org/mozilla-central/rev/01a1a9d50106
Comment 13 Alex Keybl [:akeybl] 2012-02-10 11:35:44 PST
This does not appear to be critical enough to track, although you can make your case for uplifting to Beta 11 in a nomination.

Note You need to log in before you can comment on or make changes to this bug.