Request: make "send link" available when right-clicking on link?

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
18 years ago
5 years ago

People

(Reporter: michael_bourgon, Assigned: mpt)

Tracking

({qawanted})

Trunk
x86
Windows NT
qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
title says it all.  I'd love to be able to either send page or send link
(preferably send link) from a right-click.  Thanks
see discussion in bug 26939, which boils down to "don't clutter context menus"....

Over to UI:DF to have mpt look at this.

For what it's worth, this is more deserving of being in the context menu than
send page.
Component: Browser-General → User Interface: Design Feedback

Comment 2

18 years ago
[you didn't reassign to mpt, just dupe this bug against an older copy of send 
link rfe]
Keywords: qawanted
Whiteboard: DUPEME

Comment 3

18 years ago
Created attachment 27895 [details]
we need another context menu like I need a hole in my head
(Reporter)

Comment 4

18 years ago
I can see your point, Asa.  The build I'm using (2001030505) only has 17 items,
not 23 (yikes!) like your attachment.  In that case, how about a shortcut?  If
'Send Link' had a [CTRL]+[something] shortcut I wouldn't have a problem, but
sending a link seems kinda basic.  (yeah, I know... new guy and he's already
telling everyone how to do their job)  View Page Source, Frame Source, Frame
Info, Page Info, and Edit Link In Composer are cool for the developers (and I do
use Info and Source), but most of those have shortcuts, and it looks like you've
run out of letters to use with [CTRL].   If anyone has any ideas, I'm all for
'em.  I'm honestly not trying to make your life harder, appearances to the contrary.

Comment 5

18 years ago
Created attachment 27906 [details]
no. but wait. there's more....ideal context menu 26 items?

Comment 6

18 years ago
not mine though. over to mpt. 
Assignee: asa → mpt
QA Contact: doronr → zach
(Reporter)

Comment 7

18 years ago
That context menu is turning into its own Platform/OS/(version of Emacs). *laugh*
Dumb question: can I use XUL to modify the standard skin on my machine to add a
[CTRL]+[letter] shortcut?  If so, I can do that.  I surf with only the personal
toolbar expanded, since it's eminently doable in Moz.
Yes, you can change the xul and js to create a new shortcut.  It might take some
work to properly adapt the code from the File menu, but certainly doable.

This would change it for all skins, not just the standard one, btw (since the
skins include no xul).

Comment 9

18 years ago
Admittedly, this IS more valid than send Page. With Send Page, you can do that
right off the File Menu. how, pray tell, does one send a Link from there? :)

Marking NEW to get it off our Radar.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Depends on: 75338

Comment 10

17 years ago
Send Link is in the context menu now...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
we should be skeptical about adding items for "future contexts". for example a
more common practice would be to enable user to send the currently viewed the
context before while they've deemed it's usefulness.

i have posted the 2nd draft to the Context Menu Revision 2 document located:

http://mozilla.org/projects/ui/communicator/framework/contextmenus/cmrev2-2.html

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.