URL autocomplete breaks keyword bookmarks

RESOLVED FIXED in Firefox 12

Status

()

Firefox
Location Bar
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Andrea, Assigned: mak)

Tracking

(Blocks: 1 bug, {regression})

12 Branch
Firefox 12
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
This is an edge case of the new URL autocomplete feature (see bug 659437, c0).

Steps to reproduce:
1) bookmark a page, e.g. facebook.com, and assign it a keywork, say "fb"
2) visit fbackup.com or any other url with domain name starting with "fb" to add it to your browsing history
3) type "fb" in the urlbar and hit ENTER

Expected results:
fb is recognized as a keyword, Firefox opens the associated bookmark, facebook.com

Actual results:
Firefox autocompletes the URL with fbackup.com and gets you there as you hit ENTER.


I think that keywords should have priority over URLs, since they are assigned by the user.
(Reporter)

Updated

5 years ago
Depends on: 659437
See Also: → bug 659437

Comment 1

5 years ago
In my opinion keywords hold higher priority and in anycase you still can press down arrow and choose desired alternative

Updated

5 years ago
Blocks: 566489, 659437
No longer depends on: 659437
Keywords: regression
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

5 years ago
I think it will be easier to fix this from the Places autocomplete implementation side, by not returning a result if the search term matches a keyword.
Assignee: nobody → mak77
(Assignee)

Comment 3

5 years ago
Created attachment 590958 [details] [diff] [review]
patch v1.0

needs a test yet, though, since all the inline ac harness is missing, it should probably just be added in bug 715133. Will check what's the best way on, if work on those tests started or not.
(Assignee)

Updated

5 years ago
Depends on: 720589
(Assignee)

Comment 4

5 years ago
Created attachment 590967 [details] [diff] [review]
patch v1.1
Attachment #590958 - Attachment is obsolete: true
(Assignee)

Comment 5

5 years ago
Created attachment 591152 [details] [diff] [review]
patch v1.1

Added a new test harness we can use in bug 715133 and a test using it
Attachment #590967 - Attachment is obsolete: true
Attachment #591152 - Flags: review?(dietrich)
(Assignee)

Updated

5 years ago
Blocks: 715133
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Flags: in-testsuite+
(Assignee)

Updated

5 years ago
No longer depends on: 720589
Comment on attachment 591152 [details] [diff] [review]
patch v1.1

>diff --git a/toolkit/components/places/tests/inline/head_autocomplete.js b/toolkit/components/places/tests/inline/head_autocomplete.js

>+function run_test() {

>+    try {
>+      Services.prefs.clearUserPref("browser.urlbar.autoFill");
>+    } catch(ex) {}
>+    try {
>+      Services.prefs.clearUserPref("places.history.enabled");
>+    } catch(ex) {}

Don't need the try/catches anymore (since bug 487059)
Attachment #591152 - Flags: review+
(Assignee)

Updated

5 years ago
Attachment #591152 - Flags: review?(dietrich)
(Assignee)

Comment 7

5 years ago
Removed the try/catch
https://hg.mozilla.org/integration/mozilla-inbound/rev/ddba51717872
Target Milestone: --- → Firefox 12
https://hg.mozilla.org/mozilla-central/rev/ddba51717872
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.