Closed Bug 720131 Opened 8 years ago Closed 8 years ago

Characters are deleted in URL bar using inline autocomplete and the Omnibar Add On

Categories

(Firefox :: Untriaged, defect)

12 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 720066

People

(Reporter: bug.zilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Attempted to type a new search term into the URL bar (which is also the search bar since Omnibar is installed)


Actual results:

The autocomplete feature searches through the history as characters are typed, but once there are no relevant hits in the history the entire search term gets deleted and you have to start from the  beginning again.


Expected results:

Even if autocomplete does not find the search term in the history it should still allow you to finish typing instead of deleting the whole thing.
This is the inline autocomplete I'm referring to:
http://www.youtube.com/watch?feature=player_embedded&v=4HAW-iCnaFU
Likely the same issue than bug 720066
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720066
You need to log in before you can comment on or make changes to this bug.